dhcpconfig(1M)          System Administration Commands          dhcpconfig(1M)

NAME

       dhcpconfig - DHCP service configuration utility

SYNOPSIS

       dhcpconfig -D -r resource -p path [-u uninterpreted]
            [-l lease_length] [-n ] [-d DNS_domain]
            [-a DNS_server_addresses] [-h hosts_resource]
            [-y hosts_domain]

       dhcpconfig -R server_addresses

       dhcpconfig -U [-f] [-x] [-h]

       dhcpconfig -N network_address [-m subnet_mask] [-b ]
            [-t router_addresses] [-y NIS-domain]
            [-a NIS_server_addresses] [-g]

       dhcpconfig -C -r resource -p path [-f] [-k]
            [-u uninterpreted]

       dhcpconfig -X filename [-m macro_list] [-o option_list]
            [-a network_addresses] [-f] [-x] [-g]

       dhcpconfig -I filename [-f] [-g]

       dhcpconfig -P [parameter[=value],]...

       dhcpconfig -S [-f] [-e | -d | -r | -q]

DESCRIPTION

       The dhcpconfig command is used to configure and manage the Dynamic Host
       Configuration Protocol (DHCP) service or BOOTP relay  services.  It  is
       intended  for  use  by experienced Solaris system administrators and is
       designed for ease of use in scripts. The dhcpmgr utility is recommended
       for  less  experienced  administrators  or those preferring a graphical
       utility to configure and manage the DHCP service or  BOOTP  relay  ser‐
       vice.

       The  dhcpconfig  command can be run by root, or by other users assigned
       to the DHCP Management profile. See rbac(5) and user_attr(4).

       dhcpconfig requires one of the following function flags:  -D,  -R,  -U,
       -N, -C, -X, -I, -P or -S.

       The  dhcpconfig menu driven mode is supported in Solaris 8 and previous
       versions of Solaris.

   Where dhcpconfig Obtains Configuration Information
       dhcpconfig scans various configuration files on  your  Solaris  machine
       for  information  it  can  use to assign values to options contained in
       macros it adds to the dhcptab configuration table. The following  table
       lists information dhcpconfig needs, the source used, and how the infor‐
       mation is used:

       ┌───────────────┬───────────────────────────────────────┬───────────────────────┐
InformationSourceWhere Used
       ├───────────────┼───────────────────────────────────────┼───────────────────────┤
       │Timezone       │ System date, timezone settings        │ Locale macro          │
       │DNS parameters │ nsswitch.conf, /etc/resolv.conf       │ Server macro          │
       │NIS parameters │ System domainname, nsswitch.conf, NIS │ Network macros        │
       │Subnetmask     │ Network interface, netmasks table  in │ Network macros        │
       │               │ nameservice                           │                       │
       └───────────────┴───────────────────────────────────────┴───────────────────────┘

       If you have not set these parameters on your server machine, you should
       do so before configuring the DHCP server with dhcpconfig. Note that  if
       you specify options with the dhcpconfig -D command line, the values you
       supply override the values obtained from the system files.

OPTIONS

       The following options are supported:

       -C                     Convert to using a new  data  store,  recreating
                              the  DHCP data tables in a format appropriate to
                              the new data store,  and  setting  up  the  DHCP
                              server to use the new data store.

                              The following sub-options are required:

                              -p path_to_data     The  paths for SUNWfiles and
                                                  SUNWbinfiles must  be  abso‐
                                                  lute   UNIX  pathnames.  The
                                                  path for SUNWnisplus must be
                                                  a   fully   specified   NIS+
                                                  directory   (including   the
                                                  tailing     period.)     See
                                                  dhcp_modules(5).

                              -r data_resource    New data store resource. One
                                                  of  the  following  must  be
                                                  specified:  SUNWfiles,  SUN‐
                                                  Wbinfiles,  or  SUNWnisplus.
                                                  See dhcp_modules(5).

                              The following sub-options are optional:

                              -f                  Do not prompt for  confirma‐
                                                  tion.  If  -f is not used, a
                                                  warning   and   confirmation
                                                  prompt are issued before the
                                                  conversion starts.

                              -k                  Keep  the  old   DHCP   data
                                                  tables after successful con‐
                                                  version.  If   any   problem
                                                  occurs   during  conversion,
                                                  tables are not deleted  even
                                                  if   -k  sub-option  is  not
                                                  specified.

                              -u uninterpreted    Data  which  is  ignored  by
                                                  dhcpconfig, but passed on to
                                                  the datastore for  interpre‐
                                                  tation.  The  private  layer
                                                  provides for module-specific
                                                  configuration    information
                                                  through  the  use   of   the
                                                  RESOURCE_CONFIG     keyword.
                                                  Uninterpreted data is stored
                                                  within  RESOURCE_CONFIG key‐
                                                  word of dhcpsvc.conf(4). The
                                                  -u  sub-option  is  not used
                                                  with the SUNWfiles, SUNWbin‐
                                                  files,  and SUNWnisplus data
                                                  stores. See dhcp_modules(5).

       -D                     Configure the DHCP service.

                              The following sub-options are required:

                              -r data_resource    One of the following must be
                                                  specified:  SUNWfiles,  SUN‐
                                                  Wbinfiles,  or  SUNWnisplus.
                                                  Other  data  stores  may  be
                                                  available.See      dhcp_mod‐
                                                  ules(5).

                              -p path             The  paths for SUNWfiles and
                                                  SUNWbinfiles must  be  abso‐
                                                  lute   UNIX  pathnames.  The
                                                  path for SUNWnisplus must be
                                                  a   fully   specified   NIS+
                                                  directory   (including   the
                                                  tailing   period.)   .   See
                                                  dhcp_modules(5).

                              The following sub-options are optional:

                              -a DNS_servers       IP   addresses    of    DNS
                                                   servers,   separated   with
                                                   commas.

                              -d DNS_domain        DNS domain name.

                              -h hosts_resource    Resource in which to  place
                                                   hosts  data.  Usually,  the
                                                   name service in use on  the
                                                   server.  Valid  values  are
                                                   nisplus, files, or dns.

                              -l seconds           Lease   length   used   for
                                                   addresses   not   having  a
                                                   specified lease length,  in
                                                   seconds.

                              -n                   Non-negotiable leases

                              -y hosts_domain      DNS  or NIS+ domain name to
                                                   be  used  for  hosts  data.
                                                   Valid  only  if dns or nis‐
                                                   plus is  specified  for  -h
                                                   sub-option.

                              -u uninterpreted     Data  which  is  ignored by
                                                   dhcpconfig, but  passed  on
                                                   to the datastore for inter‐
                                                   pretation.   The    private
                                                   layer  provides for module-
                                                   specific      configuration
                                                   information through the use
                                                   of   the    RESOURCE_CONFIG
                                                   keyword. Uninterpreted data
                                                   is      stored       within
                                                   RESOURCE_CONFIG  keyword of
                                                   dhcpsvc.conf(4).   The   -u
                                                   sub-option is not used with
                                                   the   SUNWfiles,   SUNWbin‐
                                                   files, and SUNWnisplus data
                                                   stores.    See    dhcp_mod‐
                                                   ules(5).

       -I filename            Import  data from filename, containing data pre‐
                              viously exported from  a  Solaris  DHCP  server.
                              Note  that after importing, you may have to edit
                              macros to specify the correct domain names,  and
                              edit  network tables to change the owning server
                              of addresses in imported  networks.  Use  dhtadm
                              and pntadm to do this.

                              The following sub-options are supported:

                              -f    Replace any conflicting data with the data
                                    being imported.

                              -g    Signal the daemon to  reload  the  dhcptab
                                    once the import has been completed.

       -N net_address         Configure  an  additional  network for DHCP ser‐
                              vice.

                              The following sub-options are supported:

                              -a NIS_server_addresses    List of IP  addresses
                                                         of NIS servers.

                              -b                         Network  is  a point-
                                                         to-point  (PPP)  net‐
                                                         work,   therefore  no
                                                         broadcast     address
                                                         should be configured.
                                                         If -b  is  not  used,
                                                         the     network    is
                                                         assumed to be a  LAN,
                                                         and   the   broadcast
                                                         address is determined
                                                         using   the   network
                                                         address  and   subnet
                                                         mask.

                              -g                         Signal  the daemon to
                                                         reload the dhcptab.

                              -m xxx.xxx.xxx.xxx         Subnet mask  for  the
                                                         network; if -m is not
                                                         used, subnet mask  is
                                                         obtained   from  net‐
                                                         masks.

                              -t router_addresses        List  of  router   IP
                                                         addresses;   if   not
                                                         specified,     router
                                                         discovery   flag   is
                                                         set.

                              -y NIS_domain_name         If  NIS  is  used  on
                                                         this network, specify
                                                         the NIS domain name.

       -P                     Configure  the  DHCP  service  parameters.  Each
                              parameter and value are specified by the follow‐
                              ing pattern:

                                parameter[=value],...

                              Where parameter and value are:

                              parameter    One of the DHCP service  parameters
                                           listed  in  dhcpsvc.conf(4). If the
                                           corresponding value is  not  speci‐
                                           fied,  the  current parameter value
                                           is displayed. If parameter  is  not
                                           specified,  all parameters and cur‐
                                           rent values are displayed.

                              value        Optional string to set the  servers
                                           parameter   to   if  the  value  is
                                           acceptable. If the value is missing
                                           or is empty (""), the parameter and
                                           its current value are deleted.

                              After a parameter has changed  the  DHCP  server
                              requires  re-starting  before  you  can  use new
                              parameter values.

       -R server_addresses    Configure the BOOTP relay service. BOOTP or DHCP
                              requests  are  forwarded  to the list of servers
                              specified.

                              server_addresses is a comma  separated  list  of
                              hostnames and/or IP addresses.

       -S                     Control the DHCP service.

                              The following sub-options are supported:

                              -d     Disable and stop the DHCP service.

                              -e    Enable and start the DHCP service.

                              -q    Display the state of the DHCP service. The
                                    state is encoded into the exit status.

                                      0    DHCP service disabled and stopped
                                      1    DHCP service enabled and stopped
                                      2    DHCP service disabled and running
                                      3    DHCP service enabled and running

                              -r    Enable and restart the DHCP service.

       -U                     Unconfigure the DHCP service or BOOTP relay ser‐
                              vice.

                              The following sub-options are supported:

                              -f    Do  not  prompt for confirmation. If -f is
                                    not  used,  a  warning  and   confirmation
                                    prompt is issued.

                              -h    Delete hosts entries from name service.

                              -x    Delete the dhcptab and network tables.

       -X filename            Export data from the DHCP data tables, saving to
                              filename, to move the data  to  another  Solaris
                              DHCP server.

                              The following sub-options are optional:

                              -a networks_to_export    List  of networks whose
                                                       addresses   should   be
                                                       exported,  or  the key‐
                                                       word ALL to specify all
                                                       networks.  If -a is not
                                                       specified, no  networks
                                                       are exported.

                              -g                       Signal  the  daemon  to
                                                       reload   the    dhcptab
                                                       after  the  export  has
                                                       been completed.

                              -m macros_to_export      List   of   macros   to
                                                       export,  or the keyword
                                                       ALL  to   specify   all
                                                       macros.  If  -m  is not
                                                       specified,  no   macros
                                                       are exported.

                              -o options_to_export     List   of   options  to
                                                       export, or the  keyword
                                                       ALL   to   specify  all
                                                       options. If -o  is  not
                                                       specified,  no  options
                                                       are exported.

                              -x                       Delete  the  data  from
                                                       this server after it is
                                                       exported. If -x is  not
                                                       specified  you  are  in
                                                       effect   copying    the
                                                       data.

EXAMPLES

       Example 1 Configuring DHCP Service with Binary Files Data Store

       The  following  command configures DHCP service, using the binary files
       data store, in the DNS domain acme.eng, with a lease time of 28800 sec‐
       onds (8 hours),

         example# dhcpconfig -D -r SUNWbinfiles -p /var/dhcp -l 28800\
                      -d acme.eng -a 120.30.33.4 -h dns -y acme.eng

       Example 2 Configuring BOOTP Relay Agent

       The  following  command  configures  the  DHCP  daemon as a BOOTP relay
       agent, which forwards BOOTP and DHCP requests to the servers having the
       IP addresses 120.30.33.7 and 120.30.42.132:

         example# dhcpconfig -R 120.30.33.7,120.30.42.132

       Example 3 Unconfiguring DHCP Service

       The following command unconfigures the DHCP service, with confirmation,
       and deletes the DHCP data tables and host table entries:

         example# dhcpconfig -U -x -h

       Example 4 Configuring a Network for DHCP Service

       The following command configures an additional  LAN  network  for  DHCP
       service,  specifying  that clients should use router discovery and pro‐
       viding the NIS domain name and NIS server address:

         example# dhcpconfig -N 120.30.171.0 -y east.acme.eng.com\
                      -a 120.30.33.4

       Example 5 Converting to SUNWnisplus Data Store

       The following command converts a DHCP  server  from  using  a  text  or
       binary  files  data  store  to a NIS+ data store, deleting the old data
       store's DHCP tables:

         example# dhcpconfig -C -r SUNWnisplus -p whatever.com.

       Example 6 Exporting a Network, Macros, and Options from a DHCP Server

       The following  command  exports  one  network  (120.30.171.0)  and  its
       addresses, the macro 120.30.171.0, and the options motd and PSptrfrom a
       DHCP    server,     saves     the     exported     data     in     file
       /export/var/120301710_data,  and  deletes  the  exported  data from the
       server.

         example# dhcpconfig -X /var/dhcp/120301710_export
              -a 120.30.171.0 -m 120.30.171.0 -o motd,PSptr

       Example 7 Importing Data on a DHCP Server

       The   following   command   imports   DHCP   data    from    a    file,
       /net/golduck/export/var/120301710_data,   containing   data  previously
       exported from a Solaris DHCP server, overwrites any conflicting data on
       the importing server, and signals the daemon to reload the dhcptab once
       the import is completed:

         example# dhcpconfig -I /net/golduck/export/var/120301710_data -f -g

       Example 8 Setting DHCP Server Parameters

        The following command sets the number of minutes that the DHCP  server
       waits  before  timing out when updating DNS information on DHCP clients
       to five minutes.

         example# example# dhcpconfig -P UPDATE_TIMEOUT=5

       Example 9 Re-starting the DHCP server

       The following command stops and re-starts the DHCP server.

         example#  example# dhcpconfig -S -r
         DHCP server stopped
         DHCP server started

ATTRIBUTES

       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE         │      ATTRIBUTE VALUE        │
       ├─────────────────────────────┼─────────────────────────────┤
       │Availability                 │SUNWdhcsu                    │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability          │Evolving                     │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO

       dhcpmgr(1M),  dhtadm(1M),  in.dhcpd(1M),  pntadm(1M),  dhcp_network(4),
       dhcptab(4),    dhcpsvc.conf(4),    nsswitch.conf(4),    resolv.conf(4),
       user_attr(4), attributes(5), dhcp(5), dhcp_modules(5), rbac(5)

SunOS 5.11                        16 Jun 2004                   dhcpconfig(1M)
Impressum