mkntfs(1M)              System Administration Commands              mkntfs(1M)

NAME

       mkntfs - create an NTFS file system

SYNOPSIS

       mkntfs [options] device [number_of_sectors]

       mkntfs [-C] [-c cluster-size] [-F] [-f] [-H heads] [-h] [-I]
            [-L volume-label] [-l] [-n] [-p part-start-sect] [-Q] [-q]
            [-S sectors-per-track] [-s sector-size] [-T] [-V] [-v]
            [-z mft-zone-multiplier] [--debug] device [number-of-sectors]

DESCRIPTION

       The  mkntfs  utility is used to create an NTFS file system on a device,
       usually a disk partition, or file.  The device operand is  the  special
       file  corresponding  to  the  device; for example, /dev/dsk/c0d0p0. The
       number-of-sectors operand is the number of blocks  on  the  device.  If
       omitted, mkntfs automatically figures the file system size.

OPTIONS

       Supported  options are listed below. Most options have both single-let‐
       ter and full-name forms. Multiple single-letter  options  that  do  not
       take an argument can be combined. For example, -fv is the equivalent of
       -f -v. A full-name option can be abbreviated to a unique prefix of  its
       name.

       Options are divided among basic, advanced, output, and help options, as
       listed below.

   Basic Options
       -C, --enable-compression

           Enable compression on the volume.

       -f, --fast or -q, --quick

           Perform quick (fast) format. This option skips both  zeroing of the
           volume and bad sector checking.

       -L, --label string

           Set the volume label for the filesystem to string.

       -n, --no-action

           Causes  mkntfs  to  not  actually create a file system, but display
           what it would do if it were to create a file system. All formatting
           steps are carried out except the actual writing to the device.

   Advanced Options
       -c, --cluster-size bytes

           Specify  the  size  of clusters in bytes. Valid cluster size values
           are powers of two, with at least 256, and at most 65536, bytes  per
           cluster.  If omitted, mkntfs uses 4096 bytes as the default cluster
           size.

           Note that the default cluster size is set to be at least  equal  to
           the  sector  size,  as  a  cluster cannot be smaller than a sector.
           Also, note that values greater than 4096 have the side effect  that
           compression  is  disabled on the volume. This is due to limitations
           in the NTFS compression algorithm used by Windows.

       -F, --force

           Force mkntfs to run, even if the specified  device is not  a  block
           special device, or appears to be mounted.

       -H, --heads num

           Specify  the  number  of  heads.  The maximum is 65535 (0xffff). If
           omitted, mkntfs attempts to determine the number of heads automati‐
           cally.  If  that fails a default of 0 is used. Note that specifying
           num is required for Windows to be able to  boot  from  the  created
           volume.

       -I, --no-indexing

           Disable  content  indexing on the volume. This option is only mean‐
           ingful on Windows 2000 and later. Windows NT 4.0 and earlier ignore
           this, as they do not implement content indexing.

       -p, --partition-start sector

           Specify  the  partition  start  sector.  The  maximum is 4294967295
           (2^32-1). If omitted, mkntfs attempts to determine  sectorautomati‐
           cally.  If that fails, a default of 0 is used. Note that specifying
           sector is required for Windows to be able to boot from the  created
           volume.

       -S, --sectors-per-track num

           Specify  the  number  of  sectors  per  track. The maximum is 65535
           (0xffff). If omitted, mkntfs attempts to  determine the  number  of
           sectors-per-track automatically and if that fails a default of 0 is
           used. Note that sectors-per-track is required  for  Windows  to  be
           able to boot from the created volume.

       -s, --sector-size bytes

           Specify  the size of sectors in bytes. Valid sector size values are
           256, 512, 1024, 2048, and 4096.  If  omitted,  mkntfs  attempts  to
           determine  the  sector-size automatically. If that fails, a default
           of 512 bytes per sector is used.

       -T, --zero-time

           Fake the time to be 00:00:00 UTC, Jan 1, 1970, instead of the  cur‐
           rent system time. This can be useful for debugging purposes.

       -z, --mft-zone-multiplier num

           Set  the  master file table (MFT) zone multiplier, which determines
           the size of the MFT zone to use on the volume. The MFT zone is  the
           area  at  the  beginning  of the volume reserved for the MFT, which
           stores the on-disk inodes (MFT  records).  It  is  noteworthy  that
           small  files  are  stored  entirely  within the inode; thus, if you
           expect to use the volume for storing large numbers  of  very  small
           files,  it  is useful to set the zone multiplier to a higher value.
           Although the MFT zone is resized on  the  fly  as  required  during
           operation  of  the  NTFS  driver, choosing an optimal value reduces
           fragmentation. Valid values are 1, 2, 3, and 4. The values have the
           following meaning:

             MFT zone        MFT zone size
             multiplier      (% of volume size)
             1       12.5% (default)
             2       25.0%
             3       37.5%
             4       50.0%

   Output Options
       --debug

           Includes  the  verbose  output from the -v option, as well as addi‐
           tional output useful for debugging mkntfs.

       -q, --quiet

           Verbose execution. Errors are written to stderr, no output to  std‐
           out occurs at all. Useful if mkntfs is run in a script.

       -v, --verbose

           Verbose execution.

   Help Options
       -h, --help

           Show a list of options with a brief description of each one.

       -l, --license

           Display the mkntfs licensing information and exit.

       -V, --version

           Display the mkntfs version number and exit.

ATTRIBUTES

       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE         │      ATTRIBUTE VALUE        │
       ├─────────────────────────────┼─────────────────────────────┤
       │Availability                 │SUNWntfsprogs                │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability          │Uncommitted                  │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO

       ntfsprogs(1M), ntfsresize(1M), ntfsundelete(1M), attributes(5)

       http://wiki.linux-ntfs.org

AUTHORS

       mkntfs  was  written by Anton Altaparmakov, Richard Russon, Erik Sornes
       and Szabolcs Szakacsits.

SunOS 5.11                        27 May 2009                       mkntfs(1M)
Impressum