poolstat(1M)            System Administration Commands            poolstat(1M)

NAME

       poolstat - report active pool statistics

SYNOPSIS

       poolstat [-p pool-list] [-r rset-list] [-T u | d ] [interval [count]]

       poolstat [-p pool-list] [-o format -r rset-list]
            [-T u | d ] [interval [count]]

DESCRIPTION

       The  poolstat utility iteratively examines all active pools on the sys‐
       tem. It reports statistics based on the selected output mode.  poolstat
       provides  options  to  examine only specified pools and report resource
       set-specific statistics.

       Without options, poolstat examines all pools, reports basic  statistics
       for their resource sets, and exits.

   DISPLAY FORMATS
       In default output format, poolstat outputs a header line and a line for
       each pool. The line begins with the pool ID and its name, followed by a
       column of statistical data for the processor set attached to the pool.

       The columns are defined as follows:

       id      Pool ID.

       pool    Pool name.

       rid     Resource set id.

       rset    Resource set name.

       type    Resource set type.

       min     Minimum resource set size.

       max     Maximum resource set size.

       size    Current resource set size.

       used    The  measure  of  how  much of the resource set is currently is
               use. This is calculated as the percentage  utilization  of  the
               resource  set  multiplied by its size. If resource set has been
               reconfigured during last sampling interval, this value might be
               not reported (-).

       load    The  absolute  representation  of  the  load that is put on the
               resource  set.  For  the  definition  of  this   property   see
               libpool(3LIB).

OPTIONS

       The following options are supported:

       -o format       Report statistics according to the format specification
                       given in format. See DISPLAY FORMATS.

                       The -o option accepts lists as arguments.  Items  in  a
                       list  can  be either separated by commas or enclosed in
                       quotes and separated by commas or spaces.

                       You can specify multiple -o options. The format  speci‐
                       fication  is  interpreted  as  the whitespace separated
                       concatenation of all the format option arguments.

                       The -o option must be used in conjunction with  the  -r
                       option.

       -p pool-list    Report only pools whose names are in the given list. If
                       the -r option is also used, this  option  selects  only
                       resource  sets which belong to pools in the given list.
                       Statistics for pools or resource sets are  reported  in
                       the  same  order  in which pool names are listed on the
                       pool-list. Pool can be specified by name or by ID.

                       The -p option accepts lists as arguments.  Items  in  a
                       pool-list can only be separated by spaces.

       -r rset-list    Report  resource set statistics. If the rset-list argu‐
                       ment is "all", then all possible resource set types are
                       selected.

                       The  -r  option  accepts lists as arguments. Items in a
                       list can be either separated by commas or  enclosed  in
                       quotes and separated by commas or spaces.

                       The following resource set types are supported:

                       all     All resource set types

                       pset    Processor set

       -T u | d        Display a time stamp.

                       Specify  u for a printed representation of the internal
                       representation of time.  See  time(2).  Specify  d  for
                       standard date format. See date(1).

OPERANDS

       The following operands are supported:

       count       The  number  of  times that the statistics are repeated. By
                   default, poolstat reports statistics only once.

                   If neither interval nor count are specified, statistics are
                   reported  once.  If interval is specified and count is not,
                   statistics are reported indefinitely.

       interval    The sampling interval in seconds.

                   If neither interval nor count are specified, statistics are
                   reported  once.  If interval is specified and count is not,
                   statistics are reported indefinitely.

EXAMPLES

       Example 1 Using poolstat

       The following example shows the default output from the poolstat  util‐
       ity:

         % poolstat
                                  pset
           id pool           size used load
            0 pool_default      4  3.6  6.2
            1 pool_admin        4  3.3  8.4

       Example 2 Reporting Resource Set Statistics

       The following example reports resource set statistics.

         % poolstat -r pset
           id pool           type rid rset          min  max size used load
           0 pool_default    pset  -1 pset_default    1  65K    2  1.2  8.3
           1 pool_admin      pset   1 pset_admin      1    1    1  0.4  5.2
           2 pool_other      pset  -1 pset_default    1  65K    2  1.2  8.3

       Resource  sets attached to multiple pools, as pset_default in the exam‐
       ple above, are listed multiple times, once for each pool.

       Example 3 Restricting the Output to the List of Pools

       The following example restricts the output to the list of pools

         % poolstat -p pool_default
                              pset
          id pool         size used load
          0 pool_default    8  5.3 10.3

         % poolstat -p 'pool_admin pool_default'
                                pset
           id pool         size used load
           1 pool_admin      6  4.3  5.3
           0 pool_default    2  1.9  2.0

         % poolstat -r all -p 'pool_admin pool_default'
           id pool            type rid rset          min  max size used load
           1 pool_admin      pset   1 pset_admin      1    1    1  0.9  2.3
           2 pool_default    pset  -1 pset_default    1  65K    2  2.0  2.0

       Example 4 Customizing Output

       The following example customizes output:

         % poolstat -r -o pool,rset,size,load
           pool            rset          size load
           pool_default    pset_default     4  4.5
           pool_admin      pset_admin       4  2.1

EXIT STATUS

       The following exit values are returned:

       0    Successful completion.

       1    An error occurred.

       2    Invalid command line options were specified.

ATTRIBUTES

       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE         │      ATTRIBUTE VALUE        │
       ├─────────────────────────────┼─────────────────────────────┤
       │Availability                 │SUNWpool                     │
       ├─────────────────────────────┼─────────────────────────────┤
       │Stability                    │Evolving                     │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO

       libpool(3LIB), attributes(5)

NOTES

       The system ids associated with resources can change  after  the  system
       reboots or the resource configuration is altered.

SunOS 5.11                        16 Jun 2009                     poolstat(1M)
Impressum