putdev(1M)              System Administration Commands              putdev(1M)

NAME

       putdev - edits device table

SYNOPSIS

       putdev -a alias [attribute=value [...]]

       putdev -m device attribute=value [attribute = value [...]]

       putdev -d device [attribute [...]]

DESCRIPTION

       putdev  adds  a  new  device  to the device table, modifies an existing
       device description or removes a device entry from the table. The  first
       synopsis is used to add a device. The second synopsis is used to modify
       existing entries by adding  or  changing  attributes.  If  a  specified
       attribute is not defined, this option adds that attribute to the device
       definition. If a specified attribute is already  defined,  it  modifies
       the  attribute  definition. The third synopsis is used to delete either
       an entire device entry or, if the attribute argument is used, to delete
       an attribute assignment for a device.

OPTIONS

       The following options are supported:

       -a    Add  a device to the device table using the specified attributes.
             The device must be referenced by its alias.

       -d    Remove a device from the device table, when executed without  the
             attributes argument. Used with the attribute argument, it deletes
             the given attribute specification for device from the table.

       -m    Modify a device entry in the device table. If  an  entry  already
             exists, it adds any specified attributes that are not defined. It
             also modifies any attributes which already have a value  with the
             value specified by this command.

OPERANDS

       The following operands are supported:

       alias        Designates the alias of the device to be added.

       attribute    Designates  a  device  attribute to be added, modified, or
                    deleted. Can be any of  the  device  attributes  described
                    under  DEVICE  ATTRIBUTES  except  alias. This prevents an
                    accidental modification or deletion of  a  device's  alias
                    from the table.

       device       Designates  the  pathname  or  alias  of the device  whose
                    attribute is to be added, modified, or removed.

       value        Designates  the  value  to  be  assigned  to  a   device's
                    attribute.

DEVICE ATTRIBUTES

       The following list shows the standard device attributes, used by appli‐
       cations such as ufsdump(1M) and ufsrestore(1M), which  can  be  defined
       for  a  device.  You  are  not limited to this list, you can define any
       attribute you like.

       alias        The unique name by which a device is known. No two devices
                    in the database may share the same alias name. The name is
                    limited in length to 14 characters and should contain only
                    alphanumeric  characters and the following special charac‐
                    ters if they are escaped with a backslash:  underscore ( _
                    ), dollar sign ($), hyphen (−), and period (.).

       bdevice      The  pathname  to the block special device node associated
                    with the device, if any. The associated major/minor combi‐
                    nation  should  be  unique  within the database and should
                    match that associated with the cdevice field, if any.  (It
                    is the administrator's responsibility to ensure that these
                    major/minor numbers are unique in the database.)

       capacity     The capacity of the device or of the  typical  volume,  if
                    removable.

       cdevice      The  pathname to the character special device node associ‐
                    ated with the device, if any. The  associated  major/minor
                    combination  should  be  unique  within  the  database and
                    should match that associated with the  bdevice  field,  if
                    any.  (It  is the administrator's responsibility to ensure
                    that these major/minor numbers are  unique  in  the  data‐
                    base.)

       cyl          Used by the command specified in the mkfscmd attribute.

       desc         A  description of any instance of a volume associated with
                    this device (such as floppy diskette).

       dpartlist    The list of disk partitions associated with  this  device.
                    Used  only  if  type=disk.  The list should contain device
                    aliases, each of which must have type=dpart.

       dparttype    The type of disk partition  represented  by  this  device.
                    Used  only if type=dpart. It should be either fs (for file
                    system) or dp (for data partition).

       erasecmd     The command string that, when executed, erases the device.

       fmtcmd       The  command  string  that,  when  executed,  formats  the
                    device.

       fsname       The  file  system  name on the file system administered on
                    this partition, as supplied to the /usr/sbin/labelit  com‐
                    mand.  This  attribute is specified only if type=dpart and
                    dparttype=fs.

       gap          Used by the command specified in the mkfscmd attribute.

       mkfscmd      The command string that, when executed, places a file sys‐
                    tem on a previously formatted device.

       mountpt      The  default  mount point to use for the device. Used only
                    if the device is  mountable.  For  disk  partitions  where
                    type=dpart and dparttype=fs, this attribute should specify
                    the location where the partition is normally mounted.

       nblocks      The number of blocks in the file  system  administered  on
                    this partition. Used only if type=dpart and dparttype=fs.

       ninodes      The  number  of  inodes in the file system administered on
                    this partition. Used only if type=dpart and dparttype=fs.

       norewind     The name of the character special device node that  allows
                    access  to  the  serial  device without rewinding when the
                    device is closed.

       pathname     Defines the pathname to an i-node  describing  the  device
                    (used for non-block or character device pathnames, such as
                    directories).

       type         A token that represents inherent qualities of the  device.
                    Standard  types  include: 9-track, ctape, disk, directory,
                    diskette, dpart, and qtape.

       volname      The volume name on the file system  administered  on  this
                    partition,  as  supplied to the /usr/sbin/labelit command.
                    Used only if type=dpart and dparttype=fs.

       volume       A text string used to describe any instance  of  a  volume
                    associated  with this device. This attribute should not be
                    defined for devices which are not removable.

EXIT STATUS

       The following exit values are returned:

       0    Successful completion.

       1    Command syntax was incorrect, an invalid option was  used,  or  an
            internal error occurred.

       2    The  device table could not be opened for reading, or a new device
            table could not be created.

       3    If executed with the -a option, indicates that  an  entry  in  the
            device  table with the alias alias already exits. If executed with
            the -m or -d options, indicates that no entry  exists  for  device
            device.

       4    Indicates  that  -d was requested and one or more of the specified
            attributes were not defined for the device.

FILES

       /etc/device.tab

ATTRIBUTES

       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE         │      ATTRIBUTE VALUE        │
       ├─────────────────────────────┼─────────────────────────────┤
       │Availability                 │SUNWcsu                      │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO

       devattr(1M), putdgrp(1M), ufsdump(1M), ufsrestore(1M), attributes(5)

SunOS 5.11                        3 Apr 1997                        putdev(1M)
Impressum