sconadm(1M)             System Administration Commands             sconadm(1M)

NAME

       sconadm - register system information

SYNOPSIS

       /usr/sbin/sconadm register -a
            [-e softwareUpdate | -E softwareUpdate]
            [-h hostname] [-l logfile] [-N]
            [-p proxy_host[:proxy_port]]
            [-r registration_profile] [-u username]
            [-x proxy_username]

       /usr/sbin/sconadm proxy [-l logfile]
            [-p proxy_host[:proxy_port]]
            [-r registration_profile] [-x proxy_username]

DESCRIPTION

       The sconadm utility is a command-line version of the Basic Registration
       GUI. In the first form of the command in the SYNOPSIS, sconadm uses the
       register  subcommand  to register a host with a registration server. In
       the second form, sconadm uses the proxy subcommand to configure all  of
       the components for software update to use an HTTP web proxy.

       The  parameters  specified with -u, -e (or -E), -h, -p, and -x override
       values specified in your registration profile. A template for this pro‐
       file,   owned  by  root,  with  read-only  permissions,  is  stored  in
       /usr/lib/breg/data/RegistrationProfile.properties.    See     registra‐
       tion_profile(4).

       For the proxy subcommand, the proxy password is stored in the Registra‐
       tionProfile.properties  file,  available  if  proxy  authentication  is
       needed.  Storage  in  the  profile  prevents proxy passwords from being
       exposed as part of a listing of processes on a system.

OPTIONS

       The following options are supported:

       -a                            Accept "Terms  of  Use  and  Binary  Code
                                     License".  Absence  of  this option means
                                     that you do not accept the license.

       -e softwareUpdate             Enable client to be managed at  the  Sun-
                                     hosted Update Connection Service.

       -E softwareUpdate             Disable client's ability to be managed at
                                     the Sun-hosted Update Connection Service.

       -h hostname                   Hostname of the machine you want to  reg‐
                                     ister.

       -l logfile                    Pathname of log file.

       -N                            Never register.

       -p proxy_host[:proxy_port]    Proxy  host  name and optional proxy port
                                     number.

       -r registration_profile       Pathname to a registration profile.

       -u username                   User name (a Sun Online Account).

       -x proxy_username             User name on the proxy host.

EXAMPLES

       Unless specified otherwise, the commands below require root  privileges
       or privileges equivalent to root. See privileges(5).

       Example 1 Registering a New System

       Assume  a file registrationprofile.properties in /tmp that contains the
       following:

         userName=user123
         password=abc123
         hostName=
         subscriptionKey=
         portalEnabled=false
         proxyHostName=
         proxyPort=
         proxyUserName=
         proxyPassword=

       To register a new system using the profile above, you enter:

         /usr/sbin/sconadm register -a -r /tmp/registrationprofile.properties

       Example 2 Reregistering a System with a Different User

       Assume a file registrationprofile.properties in /tmp with the  contents
       shown below. Note the changed specification for userName and password.

         userName=newuser
         password=newpassword
         hostName=
         subscriptionKey=
         portalEnabled=false
         proxyHostName=
         proxyPort=
         proxyUserName=
         proxyPassword=

       To  reregister a new system using the profile above, you enter the same
       command you entered to register the system:

         /usr/sbin/sconadm register -a -r /tmp/registrationprofile.properties

       Example 3 Reregistering a System, Adding a Sun Subscription Key

       Modify registrationprofile.properties as follows:

         userName=newuser
         password=newpassword
         hostName=
         subscriptionKey=abc12345678
         portalEnabled=false
         proxyHostName=
         proxyPort=
         proxyUserName=
         proxyPassword=

       Run the command:

         /usr/sbin/sconadm register -a -r /tmp/registrationprofile.properties

       Example 4 Reregistering and Enabling Access to  all  Update  Connection
       Services

       Modify registrationprofile.properties as follows:

         userName=newuser
         password=newpassword
         hostName=
         subscriptionKey=abc12345678
         portalEnabled=false
         proxyHostName=
         proxyPort=
         proxyUserName=
         proxyPassword=

       Note that portalEnabled is set to false. Run the command:

         /usr/sbin/sconadm register -a -r /tmp/registrationprofile.properties \
         -e softwareUpdate

       Example 5 Never Registering

       To never register a system, enter:

         /usr/sbin/sconadm register -N

       Example 6 Using a Proxy Server With Proxy Authentication

       Edit registrationprofile.properties as follows:

         userName=
         password=
         hostName=
         subscriptionKey=
         portalEnabled=
         proxyHostName=webcache.mycompany.com
         proxyPort=8080
         proxyUserName=myCompanyProxyUserName
         proxyPassword=myCompanyProxyPassword

       Run the command:

         /usr/sbin/sconadm proxy -r /tmp/registrationprofile.properties

       Example 7 Changing Proxy Host Settings

       Edit registrationprofile.properties as follows:

         userName=
         password=
         hostName=
         subscriptionKey=
         portalEnabled=
         proxyHostName=webcache.mycompany.com
         proxyPort=8080
         proxyUserName=myCompanyProxyUserName
         proxyPassword=myCompanyProxyPassword

       Run the command:

         /usr/sbin/sconadm proxy -r /tmp/registrationprofile.properties

       Then, change the proxyHostName value by running the following command:

         /usr/sbin/sconadm proxy -r /tmp/registrationprofile.properties \
         -p newproxy.mycompany.com

       After the preceding command all proxies use newproxy.mycompany.com.

       Example 8 Resetting a System Not to Use a Proxy

       Edit registrationprofile.properties as follows:

         userName=
         password=
         hostName=
         subscriptionKey=
         portalEnabled=
         proxyHostName=
         proxyPort=
         proxyUserName=
         proxyPassword=

       Note that values for all proxy fields are null.

       Run the command:

         /usr/sbin/sconadm proxy -r /tmp/registrationprofile.properties

EXIT STATUS

       0     Success.

       >0    An error occurred.

FILES

       /usr/lib/breg/data/RegistrationProfile.properties

           Registration profile template.

ATTRIBUTES

       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE         │      ATTRIBUTE VALUE        │
       ├─────────────────────────────┼─────────────────────────────┤
       │Availability                 │SUNWbrg                      │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability          │Stable                       │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO

       registration_profile(4), attributes(5), privileges(5)

SunOS 5.11                        27 Feb 2006                      sconadm(1M)
Impressum