ticlts(7D)                          Devices                         ticlts(7D)

NAME

       ticlts, ticots, ticotsord - loopback transport providers

SYNOPSIS

       #include <sys/ticlts.h>

       #include <sys/ticots.h>

       #include <sys/ticotsord.h>

DESCRIPTION

       The  devices  known  as  ticlts,  ticots, and ticotsord  are ``loopback
       transport providers,'' that is, stand-alone networks at  the  transport
       level.  Loopback  transport  providers are transport providers in every
       sense except one: only one host (the local machine) is ``connected to''
       a  loopback  network. Loopback transports present a TPI (STREAMS-level)
       interface to application processes and are intended to be accessed  via
       the  TLI  (application-level)  interface. They are implemented as clone
       devices and support address spaces  consisting  of  ``flex-addresses,''
       that  is, arbitrary sequences of octets of length > 0, represented by a
       netbuf structure.

       ticlts is a datagram-mode transport provider.  It  offers  (connection‐
       less)  service of type T_CLTS. Its default address size is TCL_DEFAULT‐
       ADDRSZ. ticlts prints  the  following  error  messages  (see   t_rcvud‐
       err(3NSL)):

       TCL_BADADDR         bad address specification

       TCL_BADOPT          bad option specification

       TCL_NOPEER          bound

       TCL_PEERBADSTATE    peer in wrong state

       ticots is a virtual circuit-mode transport provider. It offers (connec‐
       tion-oriented) service of type T_COTS.  Its  default  address  size  is
       TCO_DEFAULTADDRSZ. ticots prints the following disconnect messages (see
       t_rcvdis(3NSL)):

       TCO_NOPEER               no listener on destination address

       TCO_PEERNOROOMONQ        peer has no room on connect queue

       TCO_PEERBADSTATE         peer in wrong state

       TCO_PEERINITIATED        peer-initiated disconnect

       TCO_PROVIDERINITIATED    provider-initiated disconnect

       ticotsord is a virtual circuit-mode transport provider,  offering  ser‐
       vice  of  type   T_COTS_ORD  (connection-oriented  service with orderly
       release). Its default address  size  is  TCOO_DEFAULTADDRSZ.  ticotsord
       prints the following disconnect messages (see t_rcvdis(3NSL)):

       TCOO_NOPEER               no listener on destination address

       TCOO_PEERNOROOMONQ        peer has no room on connect queue

       TCOO_PEERBADSTATE         peer in wrong state

       TCOO_PEERINITIATED        provider-initiated disconnect

       TCOO_PROVIDERINITIATED    peer-initiated disconnect

USAGE

       Loopback  transports  support  a  local  IPC  mechanism through the TLI
       interface. Applications implemented in a transport provider-independent
       manner on a client-server model using this IPC are transparently trans‐
       portable to networked environments.

       Transport provider-independent applications must not include the  head‐
       ers  listed  in  the synopsis section above. In particular, the options
       are (like all transport provider options) provider dependent.

       ticlts and ticots support the same service types  (T_CLTS  and  T_COTS)
       supported by the OSI transport-level model.

       ticotsord  supports  the same service type (T_COTSORD) supported by the
       TCP/IP model.

FILES

       /dev/ticlts

       /dev/ticots

       /dev/ticotsord

SEE ALSO

       t_rcvdis(3NSL), t_rcvuderr(3NSL)

SunOS 5.11                        3 Jul 1990                        ticlts(7D)
Impressum