RD(9F)                   Kernel Functions for Drivers                   RD(9F)

NAME

       RD, rd - get pointer to the read queue

SYNOPSIS

       #include <sys/stream.h>
       #include <sys/ddi.h>

       queue_t *RD(queue_t *q);

INTERFACE LEVEL

       Architecture independent level 1 (DDI/DKI).

PARAMETERS

       q    Pointer to the write queue whose read queue is to be returned.

DESCRIPTION

       The  RD()  function  accepts  a  write queue pointer as an argument and
       returns a pointer to the read queue of the same module.

       CAUTION: Make sure the argument to this function  is  a  pointer  to  a
       write  queue.  RD()  will  not check for queue type, and a system panic
       could result if it is not the right type.

RETURN VALUES

       The pointer to the read queue.

CONTEXT

       The RD() function can be called from user, interrupt,  or  kernel  con‐
       text.

EXAMPLES

       Example 1 Function page reference

       See the qreply(9F) function page for an example of RD().

SEE ALSO

       qreply(9F), WR(9F)

       Writing Device Drivers

       STREAMS Programming Guide

SunOS 5.11                        16 Jan 2006                           RD(9F)
Impressum