bzero(9F)                Kernel Functions for Drivers                bzero(9F)

NAME

       bzero - clear memory for a given number of bytes

SYNOPSIS

       #include <sys/types.h>
       #include <sys/ddi.h>

       void bzero(void *addr, size_t bytes);

INTERFACE LEVEL

       Architecture independent level 1 (DDI/DKI).

PARAMETERS

       addr     Starting virtual address of memory to be cleared.

       bytes    The number of bytes to clear starting at addr.

DESCRIPTION

       The  bzero()  function clears a contiguous portion of memory by filling
       it with zeros.

CONTEXT

       The bzero() function can be called from user, interrupt, or kernel con‐
       text.

SEE ALSO

       bcopy(9F), clrbuf(9F), kmem_zalloc(9F)

       Writing Device Drivers

WARNINGS

       The  address  range specified must be within the kernel space. No range
       checking is done.  If  an  address  outside  of  the  kernel  space  is
       selected, the driver may corrupt the system in an unpredictable way.

SunOS 5.11                        16 Jan 2006                        bzero(9F)
Impressum