csx_DeregisterClient(9F) Kernel Functions for Drivers csx_DeregisterClient(9F)

NAME

       csx_DeregisterClient - remove client from Card Services list

SYNOPSIS

       #include <sys/pccard.h>

       int32_t csx_DeregisterClient(client_handle_t ch);

INTERFACE LEVEL

       Solaris DDI Specific (Solaris DDI)

PARAMETERS

       ch     Client handle returned from csx_RegisterClient(9F).

DESCRIPTION

       This  function  removes  a  client  from the list of registered clients
       maintained by Card Services. The Client Handle returned  by  csx_Regis‐
       terClient(9F) is passed in the client_handle_t argument.

       The client must have returned all requested resources before this func‐
       tion is called. If any resources have not been released,  CS_IN_USE  is
       returned.

RETURN VALUES

       CS_SUCCESS                  Successful operation.

       CS_BAD_HANDLE               Client handle is invalid.

       CS_IN_USE                   Resources not released by this client.

       CS_UNSUPPORTED_FUNCTION     No PCMCIA hardware installed.

CONTEXT

       This function may be called from user or kernel context.

SEE ALSO

       csx_RegisterClient(9F)

       PC Card 95 Standard, PCMCIA/JEIDA

WARNINGS

       Clients  should  be  prepared  to receive callbacks until Card Services
       returns from this request successfully.

SunOS 5.11                        19 Jul 1996         csx_DeregisterClient(9F)
Impressum