ddi_dma_devalign(9F)     Kernel Functions for Drivers     ddi_dma_devalign(9F)

NAME

       ddi_dma_devalign - find DMA mapping alignment and minimum transfer size

SYNOPSIS

       #include <sys/conf.h>
       #include <sys/ddi.h>
       #include <sys/sunddi.h>

       int ddi_dma_devalign(ddi_dma_handle_t handle, uint_t *alignment,
            uint_t *minxfr);

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI). This interface is obsolete.

PARAMETERS

       handle       The   DMAhandle   filled   in  by  a  successful  call  to
                    ddi_dma_setup(9F).

       alignment    A pointer to an unsigned integer to be filled in with  the
                    minimum required alignment for DMA. The alignment is guar‐
                    anteed to be a power of two.

       minxfr       A pointer to an unsigned integer to be filled in with  the
                    minimum   effective   transfer  size  (see  ddi_iomin(9F),
                    ddi_dma_lim_sparc(9S) and ddi_dma_lim_x86(9S)). This  also
                    is guaranteed to be a power of two.

DESCRIPTION

       The  ddi_dma_devalign() Function determines after a successful DMA map‐
       ping (see ddi_dma_setup(9F)) the minimum required  data  alignment  and
       minimum DMA transfer size.

RETURN VALUES

       The ddi_dma_devalign() function returns:

       DDI_SUCCESS    The alignment and minxfr values have been filled.

       DDI_FAILURE    The handle was illegal.

CONTEXT

       The  ddi_dma_devalign() function can be called from user, interrupt, or
       kernel context.

ATTRIBUTES

       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE         │      ATTRIBUTE VALUE        │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability          │Obsolete                     │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO

       ddi_dma_setup(9F),        ddi_iomin(9F),         ddi_dma_lim_sparc(9S),
       ddi_dma_lim_x86(9S), ddi_dma_req(9S)

       Writing Device Drivers

SunOS 5.11                        04 Apr 2006             ddi_dma_devalign(9F)
Impressum