ddi_get_cred(9F)         Kernel Functions for Drivers         ddi_get_cred(9F)

NAME

       ddi_get_cred  -  returns  a  pointer to the credential structure of the
       caller

SYNOPSIS

       #include <sys/types.h>
       #include <sys/ddi.h>
       #include <sys/sunddi.h>

       cred_t *ddi_get_cred(void)

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI).

DESCRIPTION

       ddi_get_cred() returns a pointer to the user  credential  structure  of
       the caller.

RETURN VALUES

       ddi_get_cred() returns a pointer to the caller's credential structure.

CONTEXT

       ddi_get_cred() can be called from user context only.

SEE ALSO

       Writing Device Drivers

SunOS 5.11                        11 Apr 1991                 ddi_get_cred(9F)
Impressum