ddi_get_eventcookie(9F)  Kernel Functions for Drivers  ddi_get_eventcookie(9F)

NAME

       ddi_get_eventcookie - retrieve a NDI event service cookie handle

SYNOPSIS

       #include <sys/dditypes.h>
       #include <sys/sunddi.h>

       int ddi_get_eventcookie(dev_info_t *dip, char *name,
            ddi_eventcookie_t *event_cookiep);

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI).

PARAMETERS

       dev_info_t *dip

           Child device node requesting the cookie.

       char *name

           NULL-terminated string containing the name of the event.

       ddi_eventcookie_t *event_cookiep

           Pointer to cookie where event cookie will be returned.

DESCRIPTION

       The ddi_get_eventcookie() function queries the device tree for a cookie
       matching the given event name and returns a reference to  that  cookie.
       The search is performed by a calling up the device tree hierarchy until
       the request is satisfied by a bus nexus  driver,  or  the  top  of  the
       dev_info tree is reached.

       The cookie returned by this function can be used to register a callback
       handler, unregister a callback handler, or post an event.

RETURN VALUES

       DDI_SUCCESS    Cookie handle is returned.

       DDI_FAILURE    Request was not serviceable by any nexus driver  in  the
                      driver's ancestral device tree hierarchy.

CONTEXT

       The  ddi_get_eventcookie()  function can be called from user and kernel
       contexts only.

ATTRIBUTES

       See attributes(5) for a description of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
ATTRIBUTE TYPE         ATTRIBUTE VALUE        
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability          │Committed                    │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO

       attributes(5), ddi_add_event_handler(9F), ddi_remove_event_handler(9F)

       Writing Device Drivers

SunOS 5.11                        6 Nov 2003           ddi_get_eventcookie(9F)
Impressum