ddi_get_kt_did(9F)       Kernel Functions for Drivers       ddi_get_kt_did(9F)

NAME

       ddi_get_kt_did - get identifier of current thread

SYNOPSIS

       #include <sys/types.h>
       #include <sys/ddi.h>
       #include <sys/sunddi.h>

       kt_did_t ddi_get_kt_did(void);

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI)

DESCRIPTION

       The  ddi_get_kt_did()  function  returns a unique 64-bit identifier for
       the currently running thread.

CONTEXT

       This routine can be called from user,  kernel,  or  interrupt  context.
       This routine cannot be called from a high-level interrupt context.

RETURN VALUES

       ddi_get_kt_did()  always returns the identifier for the current thread.
       There are no error conditions.

SEE ALSO

       Writing Device Drivers

NOTES

       The value returned by this function can also be seen in adb or  mdb  as
       the did field displayed when using the thread macro.

       This interface is intended for tracing and debugging purposes.

SunOS 5.11                        15 May 2001               ddi_get_kt_did(9F)
Impressum