ddi_get_pid(9F)          Kernel Functions for Drivers          ddi_get_pid(9F)

NAME

       ddi_get_pid - returns the process ID

SYNOPSIS

       #include <sys/types.h>
       #include <sys/ddi.h>
       #include <sys/sunddi.h>

       pid_t ddi_get_pid(void);

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI).

DESCRIPTION

       ddi_get_pid() obtains the process ID of the current process. This value
       can be used to allow only a select process to perform a certain  opera‐
       tion. It can also be used to determine whether a device context belongs
       to the current process.

RETURN VALUES

       ddi_get_pid() returns the process ID.

CONTEXT

        This routine can be called from user context only.

SEE ALSO

       drv_getparm(9F)

       Writing Device Drivers

        STREAMS Programming Guide

SunOS 5.11                        18 Feb 1998                  ddi_get_pid(9F)
Impressum