ddi_node_name(9F)        Kernel Functions for Drivers        ddi_node_name(9F)

NAME

       ddi_node_name - return the devinfo node name

SYNOPSIS

       #include <sys/ddi.h>
       #include <sys/sunddi.h>

       char *ddi_node_name(dev_info_t *dip);

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI).

PARAMETERS

       dip    A pointer the device's dev_info structure.

DESCRIPTION

       The  ddi_node_name() function returns the device node name contained in
       the dev_info node pointed to by dip.

RETURN VALUES

       The ddi_node_name() function returns the device node name contained  in
       the dev_info structure.

CONTEXT

       The  ddi_node_name()  function  can  be called from user, interrupt, or
       kernel context.

SEE ALSO

       ddi_binding_name(9F)

       Writing Device Drivers

SunOS 5.11                        16 Jan 2006                ddi_node_name(9F)
Impressum