ddi_remove_event_handler(9KFe)rnel Functions for Drivedrdsi_remove_event_handler(9F)

NAME

       ddi_remove_event_handler - remove an NDI event service callback handler

SYNOPSIS

       #include <sys/dditypes.h>
       #include <sys/sunddi.h>

       int ddi_remove_event_handler(ddi_registration_id_t id);

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI).

PARAMETERS

       ddi_registration_id_t id    Unique  system  wide registration ID return
                                   by ddi_add_event_handler(9F) upon  success‐
                                   ful registration.

DESCRIPTION

       The  ddi_remove_event_handler()  function  removes the callback handler
       specified by the registration id (ddi_registration_id_t). Upon success‐
       ful  removal,  the callback handler is removed from the system and will
       not be invoked in the face of the event.

RETURN VALUES

       DDI_SUCCESS    Callback handler removed successfully.

       DDI_FAILURE    Failed to remove callback handler.

CONTEXT

       The ddi_remove_event_handler() function can be  called  from  user  and
       kernel contexts only.

ATTRIBUTES

       See attributes(5) for a description of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
ATTRIBUTE TYPE         ATTRIBUTE VALUE        
       ├─────────────────────────────┼─────────────────────────────┤
       │Stability Level              │Committed                    │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO

       attributes(5), ddi_add_event_handler(9F), ddi_get_eventcookie(9F)

       Writing Device Drivers

NOTES

       Device  drivers  must  remove  all  registered callback handlers before
       detach(9E) processing for that device instance is complete.

SunOS 5.11                        2 May 2003      ddi_remove_event_handler(9F)
Impressum