ddi_report_dev(9F)       Kernel Functions for Drivers       ddi_report_dev(9F)

NAME

       ddi_report_dev - announce a device

SYNOPSIS

       #include <sys/conf.h>
       #include <sys/ddi.h>
       #include <sys/sunddi.h>

       void ddi_report_dev(dev_info_t *dip);

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI).

PARAMETERS

       dip     a pointer the device's dev_info structure.

DESCRIPTION

       ddi_report_dev()  prints  a banner at boot time,  announcing the device
       pointed to by dip. The banner is always placed in  the  system  logfile
       (displayed  by  dmesg(1M)), but is only displayed on the console if the
       system was booted with the verbose (-v) argument.

CONTEXT

       ddi_report_dev() can be called from user context.

SEE ALSO

       dmesg(1M), kernel(1M)

       Writing Device Drivers

SunOS 5.11                        7 Jun 1993                ddi_report_dev(9F)
Impressum