ldi_ev_remove_callbacks(9FK)ernel Functions for Driverlsdi_ev_remove_callbacks(9F)

NAME

       ldi_ev_remove_callbacks - remove all callbacks for a given callback ID

SYNOPSIS

       #include <sys/sunldi.h>

       void ldi_ev_remove_callbacks(ldi_ev_callback_id_t id);

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI)

PARAMETERS

       ldi_ev_callback_id_t id

           An   opaque   data   structure  returned  on  successful  calls  to
           ldi_ev_register_callbacks(9F).

DESCRIPTION

       The ldi_ev_remove_callback() function unregisters  any  callbacks  that
       were  registered  via ldi_ev_register_callbacks(9F). Once this function
       returns, the callback ID is no longer valid.

       The finalize and notify callbacks exist independently of the LDI handle
       and  are  not  automatically removed when the LDI handle is closed. The
       layered driver removes these callbacks via  ldi_ev_remove_callbacks()()
       when  the  callbacks  are no longer needed. The LDI framework may panic
       the system if the entity registering the callback (a dev_t, dip or mod‐
       ule)  no  longer  exists  on the system and the callbacks have not been
       unregistered.

RETURN VALUES

       None.

CONTEXT

       This function can be called from user and kernel contexts only.

SEE ALSO

       ldi_ev_get_cookie(9F), ldi_ev_register_callbacks(9F)

SunOS 5.11                        21 Aug 2007      ldi_ev_remove_callbacks(9F)
Impressum