mcopymsg(9F)             Kernel Functions for Drivers             mcopymsg(9F)

NAME

       mcopymsg - Copy message contents into a buffer and free message

SYNOPSIS

       #include <sys/stream.h>
       #include <sys/strsun.h>

       void mcopymsg(mblk_t *mp, void *buf);

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI).

PARAMETERS

       mp     Message to be copied.

       buf    Buffer in which to copy.

DESCRIPTION

       The  mcopymsg()  function  copies the contents of the specified message
       into the specified buffer. If the message consists of more than a  sin‐
       gle  message  block, the contents of each message block are placed con‐
       secutively into the buffer. After copying the message contents to  buf,
       mcopymsg() frees the message mp.

       The provided buffer must be large enough to accommodate the message. If
       the buffer is not large enough, the results are unspecified.  The  msg‐
       size(9F)  function  can be used to calculate the total size of the mes‐
       sage beforehand.

RETURN VALUES

       None.

CONTEXT

       This function can be called from user, kernel or interrupt context.

SEE ALSO

       freemsg(9F), msgsize(9F)

       STREAMS Programming Guide

SunOS 5.11                        16 Oct 2007                     mcopymsg(9F)
Impressum