miocpullup(9F)           Kernel Functions for Drivers           miocpullup(9F)

NAME

       miocpullup - Prepare the payload of an M_IOCTL message for access

SYNOPSIS

       #include <sys/stream.h>
       #include <sys/strsun.h>

       int miocpullup(mblk_t *mp, size_t size);

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI).

PARAMETERS

       mp      M_IOCTL message.

       size    Number of bytes to prepare.

DESCRIPTION

       The miocpullup() function prepares the payload of the specified M_IOCTL
       message for access by ensuring that it consists of at least size  bytes
       of data.

       If  the  M_IOCTL  message  is transparent, or its total payload is less
       than size bytes, an error is returned.  Otherwise, the payload is  con‐
       catenated  as  necessary  to provide contiguous access to at least size
       bytes of data. As a special case, if size is zero, miocpullup() returns
       successfully, even if no payload exists.

RETURN VALUES

       Zero is returned on success. Otherwise an errno value is returned indi‐
       cating the problem.

CONTEXT

       This function can be called from user, kernel or interrupt context.

SEE ALSO

       STREAMS Programming Guide

SunOS 5.11                        9 June 2004                   miocpullup(9F)
Impressum