net_getpmtuenabled(9F)   Kernel Functions for Drivers   net_getpmtuenabled(9F)

NAME

       net_getpmtuenabled  -  determine if path MTU discovery is enabled for a
       network protocol

SYNOPSIS

       #include <sys/neti.h>

       int net_getpmtuenabled(const net_data_t net);

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI).

PARAMETERS

       net    value  returned   from   a   successful   call   to   net_proto‐
              col_lookup(9F).

DESCRIPTION

       The  net_getpmtuenabled()  function returns a value to indicate whether
       or not path MTU (PMTU) discovery is enabled for this network protocol.

RETURN VALUES

       The net_getpmtuenabled() function returns:

       -1    The network protocol does not support this function.

       0     PATH MTU discovery is disabled.

       1     PATH MTU discovery is enabled.

CONTEXT

       The net_getpmtuenabled() function may be called from user,  kernel,  or
       interrupt context.

ATTRIBUTES

       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE         │      ATTRIBUTE VALUE        │
       ├─────────────────────────────┼─────────────────────────────┤
       │Availability                 │SUNWcsu                      │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability          │Committed                    │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO

       net_getmtu(9F), net_protocol_lookup(9F)

SunOS 5.11                        1 May 2008            net_getpmtuenabled(9F)
Impressum