net_hook_unregister(9F)  Kernel Functions for Drivers  net_hook_unregister(9F)

NAME

       net_hook_unregister  - disable a hook that was called in event process‐
       ing

SYNOPSIS

       #include <sys/neti.h>

       int net_hook_unregister(const net_data_t net, nethook_t hook);

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI).

PARAMETERS

       net     value returned from a successful  call  to  net_protocol_regis‐
               ter().

       hook    value returned from a successful call to net_hook_register(9F).

DESCRIPTION

       The  net_hook_unregister()  function  disables  the callback hooks that
       were registered with the net_hook_register() function.

RETURN VALUES

       If the net_hook_unregister() function succeeds, 0 is  returned.  Other‐
       wise, an error indicating the problem      encountered.

CONTEXT

       The  net_hook_unregister() function may be called from user, kernel, or
       interrupt context.

ATTRIBUTES

       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE         │      ATTRIBUTE VALUE        │
       ├─────────────────────────────┼─────────────────────────────┤
       │Availability                 │SUNWcsu                      │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability          │Committed                    │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO

       net_hook_register(9F)

SunOS 5.11                        1 May 2008           net_hook_unregister(9F)
Impressum