net_instance_register(9F)Kernel Functions for Driversnet_instance_register(9F)

NAME

       net_instance_register  -  register  a set of instances to occur with IP
       instance events

SYNOPSIS

       #include <sys/neti.h>

       int net_instance_register(net_instance_t *instances);

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI).

PARAMETERS

       instances    must be a pointer returned by net_instance_alloc(9F).

DESCRIPTION

       The net_instance_register() function attempts  to  record  the  set  of
       functions  passed  by  instances  that  are  to be called when an event
       related to IP instance maintenance occurs.

RETURN VALUES

       If  the  net_instance_register()  function  succeeds,  DDI_SUCCESS   is
       returned. Otherwise, DDI_FAILURE is returned to indicate failure due to
       the name in the instance already being present.

CONTEXT

       The net_instance_register() function may be called from user or  kernel
       context.

ATTRIBUTES

       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE         │      ATTRIBUTE VALUE        │
       ├─────────────────────────────┼─────────────────────────────┤
       │Availability                 │SUNWcsu                      │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability          │Committed                    │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO

       net_instance_alloc(9F),   net_instance_unregister(9F),   attributes(5),
       net_instance_t(9S)

SunOS 5.11                        1 May 2008         net_instance_register(9F)
Impressum