net_zoneidtonetid(9F)    Kernel Functions for Drivers    net_zoneidtonetid(9F)

NAME

       net_zoneidtonetid  -  map  a  zoneid_t struture identifier to a netid_t
       structure

SYNOPSIS

       #include <sys/neti.h>

       netid_t net_zoneidtonetid(const zoneid_t zone);

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI).

PARAMETERS

       zone    valid zoneid_t structure that refers to a running zone.

DESCRIPTION

       The net_zoneidtonetid() function  maps  the  given  zoneid_t  structure
       (used  to  represent  a  zone that is currently running) into a netid_t
       structure that is associated with the IP  instance  supporting  network
       functions for that zone.

RETURN VALUES

       The  net_zoneidtonetid()  function returns -1 if no mapping took place.
       Otherwise, it returns the  netid_t  structure  currently  used  by  the
       zoneid_t  structure. For zones that are using a shared IP instance, the
       netid_t structure  for  the  instance  owned  by  the  global  zone  is
       returned.

CONTEXT

       The  net_zoneidtonetid()  function may be called from user,  kernel, or
       interrupt context.

ATTRIBUTES

       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE         │      ATTRIBUTE VALUE        │
       ├─────────────────────────────┼─────────────────────────────┤
       │Availability                 │SUNWcsu                      │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability          │Committed                    │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO

       net_netidtozonid(9F), attributes(5)

SunOS 5.11                        1 May 2008             net_zoneidtonetid(9F)
Impressum