nochpoll(9F)             Kernel Functions for Drivers             nochpoll(9F)

NAME

       nochpoll - error return function for non-pollable devices

SYNOPSIS

       #include <sys/ddi.h>
       #include <sys/sunddi.h>

       int nochpoll(dev_t dev, short events, int anyyet, short *reventsp,
             struct pollhead **pollhdrp);

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI).

PARAMETERS

       dev         Device number.

       events      Event flags.

       anyyet      Check current events only.

       reventsp    Event flag pointer.

       pollhdrp    Poll head pointer.

DESCRIPTION

       The  nochpoll()  function  is  a  routine that simply returns the value
       ENXIO. It is intended to be used  in  the  cb_ops(9S)  structure  of  a
       device driver for devices that do not support the poll(2) system call.

RETURN VALUES

       The nochpoll() function returns ENXIO.

CONTEXT

       The  nochpoll()  function can be called from user, interrupt, or kernel
       context.

SEE ALSO

       poll(2), chpoll(9E), cb_ops(9S)

       Writing Device Drivers

SunOS 5.11                        16 Jan 2006                     nochpoll(9F)
Impressum