nulldev(9F)              Kernel Functions for Drivers              nulldev(9F)

NAME

       nulldev - zero return function

SYNOPSIS

       #include <sys/conf.h>
       #include <sys/ddi.h>

       int nulldev();

INTERFACE LEVEL

       Architecture independent level 1 (DDI/DKI).

DESCRIPTION

       nulldev()  returns  0. It is intended to be used in the cb_ops(9S) data
       structure of a device driver for device entry points that do nothing.

RETURN VALUES

       nulldev() returns a 0.

CONTEXT

       nulldev() can be called from any context.

SEE ALSO

       nodev(9F), cb_ops(9S)

       Writing Device Drivers

SunOS 5.11                        11 Apr 1991                      nulldev(9F)
Impressum