putnext(9F)              Kernel Functions for Drivers              putnext(9F)

NAME

       putnext - send a message to the next queue

SYNOPSIS

       #include <sys/stream.h>
       #include <sys/ddi.h>

       void putnext(queue_t *q, mblk_t *mp);

INTERFACE LEVEL

       Architecture independent level 1 (DDI/DKI).

PARAMETERS

       q     Pointer to the queue from which the message mp will be sent.

       mp    Message to be passed.

DESCRIPTION

       The putnext() function is used to pass a message to the put(9E) routine
       of the next queue in the stream.

RETURN VALUES

       None.

CONTEXT

       The putnext() function can be called from user,  interrupt,  or  kernel
       context.

EXAMPLES

       See allocb(9F) for an example of using putnext().

SEE ALSO

       put(9E), allocb(9F), put(9F), qprocson(9F)

       Writing Device Drivers

       STREAMS Programming Guide

NOTES

       The  put()  and  putnext() functions should be called only after qproc‐
       son() is finished.

SunOS 5.11                        16 Jan 2006                      putnext(9F)
Impressum