rmalloc_wait(9F)         Kernel Functions for Drivers         rmalloc_wait(9F)

NAME

       rmalloc_wait - allocate space from a resource map, wait if necessary

SYNOPSIS

       #include <sys/map.h>
       #include <sys/ddi.h>

       unsigned long rmalloc_wait(struct map *mp, size_t size);

INTERFACE LEVEL

       Architecture independent level 1 (DDI/DKI).

PARAMETERS

       mp      Pointer  to  the  resource  map from which space is to be allo‐
               cated.

       size    Number of units of space to allocate.

DESCRIPTION

       The rmalloc_wait() function requests an  allocation  of  space  from  a
       resource  map.  rmalloc_wait()  is  similar to the rmalloc(9F) function
       with the exception that it will wait for space to become  available  if
       necessary.

RETURN VALUES

       The rmalloc_wait() function returns the base of the allocated space.

CONTEXT

       This  function  can  be called from user, interrupt, or kernel context.
       However, in most cases rmalloc_wait() should not be called from  inter‐
       rupt context.

SEE ALSO

       rmalloc(9F), rmallocmap(9F), rmfree(9F), rmfreemap(9F)

       Writing Device Drivers

SunOS 5.11                        16 Jan 2006                 rmalloc_wait(9F)
Impressum