scsi_hba_probe(9F)       Kernel Functions for Drivers       scsi_hba_probe(9F)

NAME

       scsi_hba_probe - default SCSI HBA probe function

SYNOPSIS

       #include <sys/scsi/scsi.h>

       int scsi_hba_probe(struct scsi_device *sd, int(*waitfunc)(void));

INTERFACE LEVEL

       Solaris architecture specific (Solaris DDI).

PARAMETERS

       sd           Pointer  to  a   scsi_device(9S)  structure describing the
                    target.

       waitfunc     NULL_FUNC or SLEEP_FUNC.

DESCRIPTION

       scsi_hba_probe()   is   a   function   providing   the   semantics   of
       scsi_probe(9F).  An  HBA  driver  may  call  scsi_hba_probe()  from its
       tran_tgt_probe(9E) entry point, to probe for the existence of a  target
       on  the  SCSI  bus,  or  the HBA may set tran_tgt_probe(9E) to point to
       scsi_hba_probe directly.

RETURN VALUES

       See scsi_probe(9F) for the return values from scsi_hba_probe().

CONTEXT

       scsi_hba_probe()   should   only   be    called    from    the    HBA's
       tran_tgt_probe(9E) entry point.

SEE ALSO

       tran_tgt_probe(9E), scsi_probe(9F), scsi_device(9S)

       Writing Device Drivers

SunOS 5.11                        30 Aug 1995               scsi_hba_probe(9F)
Impressum