unbufcall(9F)            Kernel Functions for Drivers            unbufcall(9F)

NAME

       unbufcall - cancel a pending bufcall request

SYNOPSIS

       #include <sys/stream.h>

       void unbufcall(bufcall_id_t id);

INTERFACE LEVEL

       Architecture independent level 1 (DDI/DKI).

PARAMETERS

       id    Identifier returned from bufcall(9F) or esbbcall(9F).

DESCRIPTION

       The  unbufcall  function  cancels  a  pending  bufcall()  or esbbcall()
       request. The argument id is a non-zero identifier for the request to be
       cancelled.  id  is  returned  from the bufcall() or esbbcall() function
       used to issue the request. unbufcall() will not return until the  pend‐
       ing  callback  is cancelled or has run. Because of this, locks acquired
       by the callback routine should not be held across the  call  to  unbuf‐
       call() or deadlock may result.

RETURN VALUES

       None.

CONTEXT

       The  unbufcall  function  can be called from user, interrupt, or kernel
       context.

SEE ALSO

       bufcall(9F), esbbcall(9F)

       Writing Device Drivers

       STREAMS Programming Guide

SunOS 5.11                        16 Jan 2006                    unbufcall(9F)
Impressum