copyreq(9S)               Data Structures for Drivers              copyreq(9S)

NAME

       copyreq  -  STREAMS  data  structure for the M_COPYIN and the M_COPYOUT
       message types

SYNOPSIS

       #include <sys/stream.h>

INTERFACE LEVEL

       Architecture independent level 1 (DDI/DKI)

DESCRIPTION

       The data structure for the M_COPYIN and the M_COPYOUT message types.

STRUCTURE MEMBERS

         int      cq_cmd;           /* ioctl command (from ioc_cmd) */
         cred_t   *cq_cr;           /* full credentials */
         uint_t   cq_id;            /* ioctl id (from ioc_id) */
         uint_t   cq_flag;          /* must be zero */
         mblk_t   *cq_private;      /* private state information */
         caddr_t  cq_addr;          /* address to copy data to/from */
         size_t   cq_size;          /* number of bytes to copy */

SEE ALSO

       STREAMS Programming Guide

SunOS 5.11                      6 October 2000                     copyreq(9S)
Impressum