copyresp(9S)              Data Structures for Drivers             copyresp(9S)

NAME

       copyresp - STREAMS data structure for the M_IOCDATA message type

SYNOPSIS

       #include <sys/stream.h>

INTERFACE LEVEL

       Architecture independent level 1 (DDI/DKI)

DESCRIPTION

       The data structure copyresp is used with the M_IOCDATA message type.

STRUCTURE MEMBERS

         int      cp_cmd;       /* ioctl command (from ioc_cmd) */
         cred_t   *cp_cr;       /* full credentials */
         uint_t   cp_id;        /* ioctl id (from ioc_id) */
         uint_t   cp_flag;      /* ioctl flags */
         mblk_t   *cp_private;  /* private state information */
         caddr_t  cp_rval;      /* status of request: 0 -> success;
                                /* non-zero -> failure */

SEE ALSO

       STREAMS Programming Guide

SunOS 5.11                        14 Nov 1996                     copyresp(9S)
Impressum