net_inject_t(9S)          Data Structures for Drivers         net_inject_t(9S)

NAME

       net_inject_t - structure for describing how to transmit a packet

SYNOPSIS

       #include <sys/neti.h>

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI).

DESCRIPTION

       The  net_inject_t  data  structure  passes information in to net_inject
       about how to transmit a packet. Transmit includes sending the packet up
       into the system as well as out of it.

STRUCTURE MEMBERS

          mblk_t                  *ni_packet;   /* start of the packet */
           struct sockaddr_storage ni_addr;      /* address of next hop */
           phy_if_t                ni_physical;  /* network interface to use */

       ni_packet      Pointer  to  the  first  the  mblk_t data structure that
                      makes up this packet.

       ni_addr        This  field  is  only  required  to  be  initialized  if
                      NI_DIRECT_OUT  is being used to transmit the packet. The
                      sockaddr_storage field must be set to  indicate  whether
                      the  destination  address  contained in the structure is
                      IPv4 (cast ni_addr to struct sockaddr_in) or IPv6  (cast
                      ni_addr to struct sockaddr_in6).

       ni_physical    The   physical   interface  where  the  packet  will  be
                      injected.

ATTRIBUTES

       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE         │      ATTRIBUTE VALUE        │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability          │Committed                    │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO

       net_inject(9F), netinfo(9F), attributes(5)

SunOS 5.11                        1 May 2008                  net_inject_t(9S)
Impressum