net_instance_t(9S)        Data Structures for Drivers       net_instance_t(9S)

NAME

       net_instance_t - packet event structure passed through to hooks

SYNOPSIS

       #include <sys/neti.h>

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI).

DESCRIPTION

       The  net_instance_t data structure defines a collection of instances to
       be called when relevant events happen within IP. The value returned  by
       the  nin_create() function is stored internally and passed back to both
       the nin_destroy() and nin_shutdown() functions as the second  argument.
       The  netid_t  passed  through  to each function can be used to uniquely
       identify each instance of IP.

STRUCTURE MEMBERS

             char    *nin_name;
              void    *(*nin_create)(const netid_t);
              void    (*nin_destroy)(const netid_t, void *);
              void    (*nin_shutdown)(const netid_t, void *);

       nin_name        Name of the owner of the instance.

       nin_create      Function to be called when a new instance of IP is cre‐
                       ated.

       nin_destroy     Function  to  be called when an instance of IP is being
                       destroyed.

       nin_shutdown    Function to be called when an instance of IP  is  being
                       shutdown. nin_shutdown() is called before nin_destroy()
                       is called.

ATTRIBUTES

       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE         │      ATTRIBUTE VALUE        │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability          │Committed                    │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO

       netinfo(9F), attributes(5)

SunOS 5.11                        1 May 2008                net_instance_t(9S)
Impressum