ddi_dma_numwin(9F)       Kernel Functions for Drivers       ddi_dma_numwin(9F)

NAME

       ddi_dma_numwin - retrieve number of DMA windows

SYNOPSIS

       #include <sys/ddi.h>
       #include <sys/sunddi.h>

       int ddi_dma_numwin(ddi_dma_handle_t handle, uint_t *nwinp);

PARAMETERS

       handle     The    DMA   handle   previously  allocated  by  a  call  to
                  ddi_dma_alloc_handle(9F).

       nwinp      Upon a successful return,  nwinp will contain the number  of
                  DMA windows for this object.

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI).

DESCRIPTION

       ddi_dma_numwin()  returns  the number of  DMA windows for a  DMA object
       if partial resource allocation was permitted.

RETURN VALUES

       ddi_dma_numwin() returns:

       DDI_SUCCESS     Successfully filled in the number of  DMA windows.

       DDI_FAILURE     DMA windows are not activated.

CONTEXT

       ddi_dma_numwin() can be called from user, kernel, or interrupt context.

SEE ALSO

       ddi_dma_addr_bind_handle(9F),                 ddi_dma_alloc_handle(9F),
       ddi_dma_buf_bind_handle(9F), ddi_dma_unbind_handle(9F)

       Writing Device Drivers

SunOS 5.11                        29 Sep 1994               ddi_dma_numwin(9F)
Impressum