hal-get-property(1M) System Administration Commands hal-get-property(1M)

 hal-get-property, hal-set-property - get and set HAL device properties

 hal-get-property --udi udi --key key [--help] [--verbose]
 [--version]

 hal-set-property --udi udi --key key {--int value | --uint64 value
 | --string value | --bool value | --strlist-pre value
 | --strlist-post value | --strlist-rem value | --double value
 | --remove value} [--help] [--version]

 The Hardware Abstraction Layer (HAL) provides a view of the various
 hardware attached to a system. This view is updated dynamically as
 hardware configuration changes by means of hotplug or other mechanisms.
 HAL represents a piece of hardware as a device object. A device object
 is identified by a unique identifer and carries a set of key/value
 pairs, referred to as device properties. Some properties are derived
 from the actual hardware, some are merged from device information files
 (.fdi files), and some are related to the actual device configuration.

 The hal-get-property and hal-set-property commands allow you to get and
 set properties of hardware that conforms to HAL specifications.

 The following options are supported:

 --udi udi

 Unique device ID.

 --key key

 Key of the property to set.

 --int

 Set value to an integer. Accepts decimal or hexadecimal value pre‐
 fixed with 0x or x.

 --uint64

 Set value to an integer. Accepts decimal or hexadecimal value pre‐
 fixed with 0x or x.

 --string value

 Set value to a string.

 --double value

 Set value to a floating point number.

 --boolean value

 Set value to a boolean, that is, true or false

 --strlist-pre value

 Prepend a string to a list.

 --strlist-post value

 Append a string to a list.

 --strlist-rem value

 Remove a string from a list.

 --remove value

 Indicates that the property should be removed.

 --version

 Display version and exit.

 --help

 Display list of options and exit

 See attributes(5) for descriptions of the following attributes:

 ┌─────────────────────────────┬─────────────────────────────┐
 │ ATTRIBUTE TYPE │ ATTRIBUTE VALUE │
 ├─────────────────────────────┼─────────────────────────────┤
 │Availability │SUNWhalr │
 ├─────────────────────────────┼─────────────────────────────┤
 │Interface Stability │Volatile │
 └─────────────────────────────┴─────────────────────────────┘

 hald(1M), attributes(5), hal(5)

SunOS 5.11 18 Aug 2006 hal-get-property(1M)