imqbrokerd(1M) System Administration Commands imqbrokerd(1M)

 imqbrokerd - start a Message Queue broker instance

 /usr/bin/imqbrokerd [option...]

 /usr/bin/imqbrokerd -h

 imqbrokerd starts an instance of the Message Queue broker. The Message
 Queue broker is the main component of a Message Queue message server.
 The broker performs reliable delivery of messages to and from Java Mes‐
 sage Service (JMS) clients.

 imqbrokerd uses command line options to specify broker configuration
 properties.

 The following options are supported:

 -backup fileName

 Back up a Master Broker's configuration change record to fileName.
 This option only applies to broker clusters.

 -cluster brokerList

 Specify the list of broker instances which are connected in a clus‐
 ter. This list is merged with the list in the imq.cluster.bro‐
 kerlist property. This option only applies to broker clusters.

 brokerList is a comma-separated list of broker instances, each
 specified by hostName:port (the host on which the broker instance
 is running and the port number it is using) If you don't specify a
 value for hostName, localhost is used. If you don't specify a value
 for port, the value of 7676 is used. For example:
 host1:8899,host2,:7878.

 -dbpassword password

 Specify the password for a plugged-in JDBC-compliant database used
 as a Message Queue data store.

 -dbuser userName

 Specify the user name for a plugged-in JDBC-compliant data store.

 -Dproperty-=value

 Set the specified broker configuration property to the value. The
 system does not validate either the configuration property or
 value. Therefore, spelling, formatting, and case is important. Mes‐
 sage Queue can not set incorrect values passed using the -D option.

 -force

 Perform action without user confirmation. This option only applies
 when you use the -remove instance option, which normally requires
 confirmation.

 -h

 Display usage help. Execute nothing else on the command line.

 -javahome path

 Specify the path to an alternate Java 2-compatible Java Development
 Kit (JDK) or Java Runtime Environment (JRE) The default is to use
 the runtime bundled with the operating system.

 -ldappassword password

 Specify the password for accessing an LDAP user repository when
 using an LDAP server (as opposed to a built-in flat-file reposi‐
 tory) to authenticate users of a Message Queue message server.

 -license [name]

 Specify the license to load, if different from the default for your
 Message Queue product edition. If you don't specify a license name,
 this lists all licenses installed on the system. Depending on the
 installed Message Queue edition, the values for name are pe (Plat‐
 form Edition-basic features), try (Platform Edition-90-day trial
 enterprise features), and unl (Enterprise Edition).

 -loglevel level

 Specify the logging level. Valid values for level are NONE, ERROR,
 WARNING, or INFO. The default value is INFO.

 -metrics int

 Report metrics at a specific interval. Specify int as the number of
 seconds.

 -name brokerName

 Specify the instance name of this broker and use the corresponding
 instance configuration file. If you do not specify a broker name,
 the name of the file is set to imqbroker. If you run more than one
 instance of a broker on the same host, each must have a unique
 name.

 -passfile filename

 Specify the name of the file from which to read the passwords for
 the SSL keystore, LDAP user repository, or JDBC-compliant database.

 -password keypassword

 Specify the password for the SSL certificate keystore.

 -port number

 Specify the broker's Port Mapper port number. By default, this is
 set to 7676. To run two instances of a broker on the same server,
 each broker's Port Mapper must have a different port number. JMS
 clients connect to the broker instance using this port number.

 -remove instance

 Remove the broker instance. Delete the instance configuration file,
 log files, data store, and other files and directories associated
 with the broker instance. This option requires user confirmation
 unless you also specify the -force option.

 -reset store|messages|durables|props

 Reset the data store (or a subset of the store) or resets the con‐
 figuration properties of the broker instance when the broker
 instance is started. The action depends on the argument provided.

 store Clear all persistent data in the data store, including
 messages, durable subscriptions, and transaction infor‐
 mation store.

 messages Clear all persistent messages durable.

 durables Clear all durable subscriptions.

 props Clear all configuration information in the config.props
 instance configuration file. All properties assume
 default values.

 -restore filename

 Replace the Master Broker's configuration change record with the
 specified backup file. This file must have been previously created
 using the -backup option. This option only applies to broker clus‐
 ters.

 -shared

 Specify that the jms connection service be implemented using the
 shared threadpool model, in which threads are shared among connec‐
 tions to increase the number of connections supported by a broker
 instance.

 -silent

 Turn off logging to the console.

 -tty

 Display all messages be to the console. WARNING and ERROR level
 messages are displayed on the console by default.

 -upgrade-store-nobackup

 Specify that an earlier, incompatible version Message Queue data
 store is automatically removed when migrating to Message Queue 3.5
 format.

 If you do not use this option, you must manually delete the earlier
 data store. This applies to both built-in (flat-file) persistence
 and plugged-in (JDBC-compliant) persistence. Migration of the ear‐
 lier data store to a Message Queue 3.5 data store takes place the
 first time you start a Message Queue 3.5 broker instance on an ear‐
 lier version data store.

 -version

 Display the version number of the installed product.

 -vmargs are [[arg]...]

 Specify arguments to pass to the Java VM. Separate arguments with
 spaces. If you want to pass more than one argument or if an argu‐
 ment contains a space, use enclosing quotation marks. For example:

 imqbrokerd -tty -vmargs " -Xmx128m -Xincgc"

 The following environment variables affect the execution of this com‐
 mand:

 IMQ_JAVAHOME Specify the Java 2 compatible runtime. When this envi‐
 ronment variable is not set it defaults to /usr/j2se.

 The following exit values are returned:

 0 Successful completion.

 >0 An error occurred.

 /etc/init.d/imq

 Shell script for starting imqbrokerd. This file looks at the
 /etc/imq/imqbrokerd.conf file.

 /etc/imq/imqbrokerd.conf

 Configuration file which controls the behavior of the broker
 startup script.

 /etc/imq/passwd

 Flat file user repository for authenticating users.

 /etc/imq/accesscontrol.properties

 Controls client access to broker functionality.

 /etc/imq/passfile.sample

 Sample passfile used by the -passfile option.

 /var/imq/instances/brokerName/props/config.properties

 Broker instance configuration file.

 See attributes(5) for descriptions of the following attributes:

 ┌─────────────────────────────┬─────────────────────────────┐
 │ ATTRIBUTE TYPE │ ATTRIBUTE VALUE │
 ├─────────────────────────────┼─────────────────────────────┤
 │Availability │SUNWiqu │
 └─────────────────────────────┴─────────────────────────────┘

 imqadmin(1M), imqcmd(1M), imqdbmgr(1M), imqkeytool(1M), imqobjmgr(1M),
 imqusermgr(1M), attributes(5)

 Sun Java System Message Queue Administrator's Guide

SunOS 5.11 11 Mar 2004 imqbrokerd(1M)