pntadm(1M) System Administration Commands pntadm(1M)

 pntadm - DHCP network table management utility

 pntadm -C [-r resource] [-p path] [-u uninterpreted] network

 pntadm -A name_IP_address [-c comment] [-e mm/dd/yyyy]
 [-f num | keywords] [-h client_hostname]
 [-i [-a] client_ID] [-m [-y] macro] [-s server]
 [-r resource] [-p path] [-u uninterpreted] network

 pntadm -M name_IP_address [-c comment] [-e mm/dd/yyyy]
 [-f num | keywords] [-h client_hostname]
 [-i [-a] client ID] [-m [-y] macro]
 [-n new_client_IP_address] [-s server] [-r resource]
 [-p path] [-u uninterpreted] network

 pntadm -D name_IP_address [-y] [-r resource] [-p path]
 [-u uninterpreted] network

 pntadm -P [-v] [-x] [-r resource] [-p path]
 [-u uninterpreted] network

 pntadm -R [-r resource] [-p path] [-u uninterpreted] network

 pntadm -L [-r resource] [-p path] [-u uninterpreted]

 pntadm -B [-v] [batchfile]

 The pntadm command is used to manage the Dynamic Host Configuration
 Protocol (DHCP) network tables. It is used to add and remove networks
 under DHCP management, and add, delete, or modify IP address records
 within network tables, or to view tables. For a description of the for‐
 mat of DHCP network tables, see dhcp_network(4).

 pntadm can be run as root or by other users assigned to the DHCP Man‐
 agement profile. See rbac(5) and user_attr(4).

 If the networks you want to add are subnetted, you need to update the
 netmasks(4) table.

 One of the following options (function flags) must be specified with
 the pntadm command: -A, -B, -C, -D, -L, -M, -P, or-R.

 The following options are supported:

 -A name_IP_address Add a client entry with hostname or client IP
 address, name_IP_address, to the named DHCP
 network table.

 The following sub-options are optional:

 -c comment Comment text. The
 default is NULL.

 -e mm/dd/yyyy Absolute lease. The
 default is 0.

 -f num | keywords Flag value. The default
 is 00.

 The flag (-f) option
 can be specified either
 as a single number
 denoting the intended
 flag value, or as a
 series of the following
 keywords, combined
 using the plus (+) sym‐
 bol:

 DYNAMIC or 00 Server
 man‐
 ager's
 assign‐
 ment.

 PERMANENT or 01 Lease
 on
 entry
 is
 per‐
 ma‐
 nent.

 MANUAL or 02 Admin‐
 is‐
 tra‐
 tor
 man‐
 aged
 assign‐
 ment.

 UNUSABLE or 04 Entry
 is
 not
 valid.

 BOOTP or 08 Entry
 reserved
 for
 BOOTP
 clients.

 For a more detailed
 description of the flag
 values, see dhcp_net‐
 work(4).

 -h client_hostname Client hostname. The
 default is NULL.

 When the -h option is
 used in this mode, the
 client_hostname is
 added to the hosts ta‐
 ble within the resource
 used for storing host
 names (files, NIS+ or
 DNS). The command will
 fail if this
 client_hostname is
 already present in the
 hosts table.

 -i client_ID [-a] Client identifier [-a].
 The default is 00.

 The -i option modified
 with -a specifies that
 the client identifier
 is in ASCII format, and
 thus needs to be con‐
 verted to hexadecimal
 format before insertion
 into the table.

 -m macro [-y] Macro name. Default is
 UNKNOWN.

 The -m option modified
 with -y verifies the
 existence of the named
 macro in the dhcptab
 table before adding the
 entry.

 -s server Server IP or name.
 Default is system name
 (uname -n).

 -B Activate batch mode. pntadm will read from
 the specified file or from standard input a
 series of pntadm commands and execute them
 within the same process. Processing many
 pntadm commands using this method is much
 faster than running an executable batchfile
 itself. Batch mode is recommended for using
 pntadm in scripts.

 The following sub-option is optional:

 -v Display commands to standard output as
 they are processed.

 -C Create the DHCP network table for the network
 specified by network. See . For details, see
 dhcp_network(4) and networks(4).

 -D name_IP_address Delete the specified client entry with host‐
 name or client IP address, name_IP_address,
 in the named DHCP network table. (See
 dhcp_network(4).)

 The following sub-option is optional:

 -y Remove associated host table entry. The
 -y option requests that all hostnames
 associated with the IP address in the
 hosts table in the resource be removed.

 -L List the DHCP network tables presently con‐
 figured, one per line, on standard output. If
 none are found, no output is printed and an
 exit status of 0 is returned.

 -M name_IP_address Modify the specified client entry with host‐
 name or client IP address, name_IP_address,
 in the named DHCP network table. See
 dhcp_network(4). The default for the sub-
 options is what they currently are set to.

 The following sub-options are optional.

 -c comment New comment
 text.

 -e mm/dd/yy New absolute
 lease expiration
 date. Time
 defaults to
 12:00 AM of the
 day specified.

 -f num | keyboard New flag value,
 see explanation
 following the
 description of
 the -A option.

 -h host_name New client host‐
 name.

 The -h option
 allows you to
 change the cur‐
 rent hostname
 associated with
 the IP address
 or to add a new
 hostname to the
 hosts table if
 an entry associ‐
 ated with this
 IP address does
 not exist.

 -i client_ID New client iden‐
 tifier [-a].

 -m macro [-y] Macro name
 defined in
 dhcptab.

 -n new_client_IP_address New IP address.

 -s server New server IP or
 name.

 For more detailed description of the sub-
 options and flag values, see dhcp_network(4).

 -P Display the named DHCP network table.

 The following sub-options are optional:

 -v Display lease time in full verbose for‐
 mat and resolve IP addresses for the
 clients and server to hostnames.

 -x Display lease time in raw format.

 These flag codes are used with the -P sub-
 options:

 -v -x Description
 D 00 DYNAMIC
 P 01 PERMANENT
 M 02 MANUAL
 U 04 UNUSABLE
 B 08 BOOTP

 See dhcp_network(4) for information on these
 sub-options and associated flag codes.

 -p path Override the dhcpsvc.conf(4) configuration
 value for data store resource path, path See
 dhcpsvc.conf(4)

 -R Remove the named DHCP network table. See
 dhcp_network(4).

 -r data_store_resource Override the /etc/inet/dhcpsvc.conf configu‐
 ration value for RESOURCE= with the
 data_store_resource specified. See the
 dhcpsvc.conf(4) man page for more details on
 resource type, and the for more information
 about adding support for other data stores.

 -u uninterpreted Data which will be ignored by pntadm, but
 passed to the currently configured public
 module to be interpreted by the data store.
 This might be used for a database account
 name or other authentication or authorization
 parameters required by a particular data
 store.

 The following operand is supported:

 network The network address or network name which corresponds to the
 dhcp network table. See dhcp_network(4).

 Example 1 Creating a Table for the 10.0.0.0 DHCP Network

 The following command creates a table for the 10.0.0.0 (subnetted to
 class C) DHCP network table. Note that if you have an alias for this
 network in your networks(4) table, you can use that value rather than
 the dotted Internet Address notation.

 example# pntadm -C 10.0.0.0

 Example 2 Adding an Entry to the 10.0.0.0 Table

 The following command adds an entry to the 10.0.0.0 table in the files
 resource in the /var/mydhcp directory:

 example# pntadm -r SUNWfiles -p /var/mydhcp -A 10.0.0.1 10.0.0.0

 Example 3 Modifying the 10.0.0.1 Entry of the 10.0.0.0 Table

 The following command modifies the 10.0.0.1 entry of the 10.0.0.0 ta‐
 ble, changing the macro name to Green, setting the flags field to MAN‐
 UAL and PERMANENT:

 example# pntadm -M 10.0.0.1 -m Green -f 'PERMANENT+MANUAL' 10.0.0.0

 Example 4 Changing the 10.0.0.1 Entry to 10.0.0.2

 The following command changes the 10.0.0.1 entry to 10.0.0.2, making an
 entry in the hosts(4) table called myclient:

 example# pntadm -M 10.0.0.1 -n 10.0.0.2 -h myclient 10.0.0.0

 Example 5 Setting the Client ID as ASCII

 The following command sets the client ID as ASCII aruba.foo.com for the
 myclient entry:

 example# pntadm -M myclient -i 'aruba.foo.com' -a 10.0.0.0

 Example 6 Deleting the myclientEntry from the 10.0.0.0 Table

 The following command deletes the myclient (10.0.0.2) entry from the
 10.0.0.0 table:

 example# pntadm -D myclient 10.0.0.0

 Example 7 Removing the Named DHCP Network Table

 The following command removes the named DHCP network table in the NIS+
 directory specified:

 example# pntadm -r SUNWnisplus -p Test.Nis.Plus. -R 10.0.0.0

 Example 8 Listing the Configured DHCP Network Tables

 The following command lists the configured DHCP network tables:

 example# pntadm -L
 192.168.0.0
 10.0.0.0

 Example 9 Executing pntadm Commands in Batch Mode

 The following command runs a series of pntadm commands contained in a
 batch file:

 example# pntadm -B addclients

 0 Successful completion.

 1 Object already exists.

 2 Object does not exist.

 3 Non-critical error.

 4 Critical error.

 /etc/inet/dhcpsvc.conf

 /etc/inet/hosts

 See attributes(5) for descriptions of the following attributes:

 ┌─────────────────────────────┬─────────────────────────────┐
 │ ATTRIBUTE TYPE │ ATTRIBUTE VALUE │
 ├─────────────────────────────┼─────────────────────────────┤
 │Availability │SUNWdhcsu │
 ├─────────────────────────────┼─────────────────────────────┤
 │Interface Stability │Evolving │
 └─────────────────────────────┴─────────────────────────────┘

 dhcpconfig(1M), dhcpmgr(1M), dhcp_network(4), , dhcpsvc.conf(4),
 dhcptab(4), hosts(4), netmasks(4), networks(4), user_attr(4),
 attributes(5), dhcp(5), dhcp_modules(5), rbac(5)

 Alexander, S., and R. Droms, DHCP Options and BOOTP Vendor Extensions,
 RFC 1533, Lachman Technology, Inc., Bucknell University, October 1993.

 Droms, R., Interoperation Between DHCP and BOOTP, RFC 1534, Bucknell
 University, October 1993.

 Droms, R., Dynamic Host Configuration Protocol, RFC 1541, Bucknell Uni‐
 versity, October 1993.

 Wimer, W., Clarifications and Extensions for the Bootstrap Protocol,
 RFC 1542, Carnegie Mellon University, October 1993.

SunOS 5.11 9 Jan 2004 pntadm(1M)