scadm(1M) System Administration Commands scadm(1M)

 scadm - administer System Controller (SC)

 /usr/platform/platform-name/sbin/scadm subcommand [option]
 [argument]...

 The scadm utility administers the System Controller (SC). This utility
 allows the host server to interact with the SC.

 The scadm utility must be run as root.

 The interface, output, and location in the directory hierarchy for
 scadm are uncommitted and might change.

 platform-name is the name of the platform implementation. Use the uname
 -i command to identify the platform implementation. See uname(1).

 The scadm utility has a number of subcommands. Some subcommands have
 specific options and arguments associated with them. See SUBCOMMANDS,
 OPTIONS, OPERANDS, and USAGE.

 SUBCOMMANDS
 Subcommands immediately follow the scadm command on the command line,
 and are separated from the command by a SPACE.

 The following subcommands are supported

 consolehistory

 Display the SC's console log. The SC maintains a running log which
 captures all console output. This log is maintained as a first-in,
 first-out buffer: New console output may displace old console out‐
 put if the buffer is full. By default, only the last eight kilo‐
 bytes of the console log file are displayed.

 The optional -a argument specifies that the entire console log file
 be displayed.

 It is possible for the SC to fill this log more quickly than the
 consolehistory subcommand can read it. This means that it is possi‐
 ble for some log data to be lost before it can be displayed. If
 this happens, the consolehistory subcommand displays "scadm: lost
 <number> bytes of console log data" in the log output, to indicate
 that some data was lost.

 The format for the consolehistory subcommand is:

 scadm consolehistory [-a]

 The consolehistory subcommand is not available on all platforms. If
 this command is used on a platform that does not support it, scadm
 prints this message:

 scadm: command/option not supported

 and exit with non-zero status.

 date

 Display the SC's time and date

 The format for the date subcommand is:

 scadm date

 download

 Program the SC's firmware.

 There are two parts to the firmware, the boot monitor and the main
 image.

 By default, The scadm command's download programs the main firmware
 image. The boot argument selects programming of the boot monitor.

 The format for the download subcommand is:

 scadm download [boot] file

 fruhistory

 Display the contents of the "field replacable unit" log maintained
 by the SC. By default, only the last eight kilobytes of the fru
 history log file are displayed. The data in contained this log con‐
 tains snapshots of the SC's "showfru" command, taken whenever the
 system is reset, or a hot-plug event is detected by the SC.

 The optional -a argument specifies that the entire fru log file be
 displayed.

 It is possible for the SC to fill this log more quickly than the
 fruhistory subcommand can read it. This means that it is possible
 for some log data to be lost before it can be displayed. If this
 happens, the fruhistory subcommand displays "scadm: lost <number>
 bytes of fru log data" in the log output, to indicate that some
 data was lost.

 The format for the fruhistory subcommand is:

 scadm fruhistory [-a]

 The fruhistory subcommand is not available on all platforms. If
 this command is used on a platform which does not support it, scadm
 prints this message:

 scadm: command/option not supported

 and exit with non-zero status.

 help

 Display a list of commands.

 The format for the help subcommand is:

 scadm help

 loghistory

 Display the most recent entries in the SC event log. The optional
 -a argument causes the entire event log history to be displayed.
 The -a argument is available only on platforms which support large
 log files. On platforms which do not support large log files, this
 flag has no additional effect.

 It is possible for the SC to fill this log more quickly than the
 loghistory subcommand can read it. This means that it is possible
 for some log data to be lost before it can be displayed. If this
 happens, the loghistory subcommand displays "scadm: lost <number>
 events" in the log output, to indicate that some data was lost.

 The format for the loghistory subcommand is:

 scadm loghistory [-a]

 resetrsc

 Reset the SC. There are two types of resets allowed, a hard reset
 and a soft reset.The hard reset is done by default. The soft reset
 can be selected by using the -s option.

 The format for the resetrsc subcommand is:

 scadm resetrsc [-s]

 send_event

 Manually send a text based event. The SC can forward the event to
 the SC event log. You can configure the -c option to send a criti‐
 cal warning to email, alert to logged in SC users, and syslog.
 Critical events are logged to syslog(3C). There is an 80 character
 limit to the length of the associated text message.

 The format for the send_event subcommand is:

 scadm send_event [-c] "message"

 set

 Set SC configuration variables to a value.

 Examples of SC configuration variables include: SC IP address
 netsc_ipaddr and SC Customer Information sc_customerinfo. See the
 output from the scadm help command for a complete list of SC con‐
 figuration variables.

 The format for the set subcommand is:

 scadm set variable value

 show

 Display the current SC configuration variable settings. If no vari‐
 able is specified, scadm shows all variable settings.

 The format for the show subcommand is:

 scadm show [variable]

 shownetwork

 Display the current network configuration parameters for SC.

 The format for the shownetwork subcommand is:

 scadm shownetwork

 useradd

 Add user accounts to the SC. The SC supports up to sixteen separate
 users.

 The format for the useradd subcommand is:

 scadm useradd username

 userdel

 Delete a user account from SC.

 The format for the userdel subcommand is:

 scadm userdel username

 userpassword

 Set a password for the user account specified. This password over‐
 rides any existing password currently set. There is no verification
 of the old password before setting the new password.

 The format for the userpassword subcommand is:

 scadm userpassword username

 userperm

 Set the permission level for the user.

 The format for the userperm subcommand is:

 scadm userperm username [aucr]

 usershow

 Display details on the specified user account. If a username is not
 specified, all user accounts are displayed.

 The format for the usershow subcommand is:

 scadm usershow username

 version

 Display the version numbers of the SC and its components.

 The format for the version subcommand is:

 scadm version [-v]

 The resetrsc, send_event, and version subcommands have associated
 options. Options follow subcommands on the command line and are sepa‐
 rated from the subcommand by a SPACE.

 The resetrsc subcommand supports the following options:

 -s

 Perform a soft reset instead of a hard reset. A hard reset physi‐
 cally resets the SC hardware. The SC software jumps to the boot
 firmware, simulating a reset, for a soft reset.

 The send_event subcommand supports the following options:

 -c

 Send a critical event. Without the -c, -send_event sends a warning.

 The version subcommand supports the following options:

 -v

 Display a verbose output of version numbers and associated informa‐
 tion.

 The consolehistory, fruhistory, and loghistory subcommands support the
 following option:

 -a

 Display the entire log. These subcommands normally display only the
 most recent log data. This flag causes them to display the entire
 log.

 The download, send_event, set, show, useradd, userdel, userperm, user‐
 show, userpassword, and userperm subcommands have associated arguments
 (operands).

 If the subcommand has an option, the arguments follow the option on the
 command line and is separated from the option by a SPACE. If the sub‐
 command does not have an option, the arguments follow the subcommand on
 the command line and are separated from the subcommand by a SPACE. If
 there are more than one arguments, they are separated from each other
 by a SPACE.

 The download subcommand supports the following arguments:

 boot

 Program the boot monitor portion of the flash. The main portion of
 the flash is programmed without any arguments

 file

 Specify file as the path to where the boot or main firmware image
 resides for download.

 Examples of file are:

 /usr/platform/platform_type/lib/image/alommainfw

 or

 /usr/platform/platform_type/lib/image/alombootfw

 The send_event subcommand supports the following arguments:

 "message"

 Describe event using the test contained in message. Enclose message
 in quotation marks.

 The set subcommand supports the following arguments:

 variable

 Set SC configuration variable.

 value

 Set SC configuration variable to value.

 The show subcommand supports the following arguments:

 variable

 Display the value of that particular variable.

 The useradd subcommand supports the following arguments:

 username

 Add new SC account username.

 The userdel subcommand supports the following arguments:

 username

 Remove SC account username.

 The userperm subcommand supports the following arguments:

 -aucr

 Set permissions for SC user accounts. If no permissions are speci‐
 fied, all four permissions are disabled and read only access is
 assigned.

 The following are the definitions for permissions:

 a

 Allow user to administer or change the SC configuration vari‐
 ables

 u

 Allow user to use the user commands to modify SC accounts

 c

 Allow user to connect to console.

 r

 Allow user to reset SC and to power on and off the host.

 username

 Change permissions on SC account username.

 The -usershow subcommand supports the following arguments:

 username

 Display information on SC account username. If usernameis not spec‐
 ified, all accounts are displayed.

 The userpassword subcommand supports the following arguments:

 username

 Set SC password for username.

 The userperm subcommand supports the following arguments:

 username

 Change SC permissions for username.

 Example 1 Displaying the SC's Date and Time

 The following command displays the SC's date and time.

 scadm date

 Example 2 Setting the SC's Configuration Variables

 The following command sets the SC's configuration variable netsc_ipaddr
 to 192.168.1.2:

 scadm set netsc_ipaddr 192.168.1.2

 Example 3 Displaying the Current SC's Configuration Settings:

 The following command displays the current SC configuration settings:

 scadm show

 Example 4 Displaying the Current Settings for a Variable

 The following command displays the current settings for the sys_host‐
 name variable:

 scadm show sys_hostname

 Example 5 Sending a Text-Based Critical Event

 The following command sends a critical event to the SC logs, alerts the
 current SC users, and sends an event to syslog(3C):

 scadm send_event -c "The UPS signaled a loss in power"

 Example 6 Sending an Informational Text-Based Event

 The following command sends an non-critical informational text based
 event to the SC event log:

 scadm send_event "The disk is close to full capacity"

 Example 7 Adding a User To the SC

 The following command adds user rscroot to the SC:

 scadm useradd rscroot

 Example 8 Deleting a User From the SC

 The following command deletes user olduser from the SC:

 scadm userdel olduser

 Example 9 Displaying User Details

 The following command displays details of all user accounts:

 scadm usershow

 Example 10 Displaying Details for a Specific User

 The following command displays details of user account rscroot:

 scadm usershow rscroot

 Example 11 Setting the User Permission Level

 The following command sets the full permission level for user rscroot
 to aucr:

 scadm userperm rscroot aucr

 Example 12 Setting the User Permission Level

 The following command sets only console access for user newuser to c:

 scadm userperm newuser c

 Example 13 Setting the User Permission Level

 The following command sets the permission level for user newuser to
 read only access:

 scadm userperm newuser

 Example 14 Displaying the Current Network Parameters

 The following command displays the current network configuation parame‐
 ters for the SC:

 scadm shownetwork

 Example 15 Viewing the Consolehistory

 The following command displays the content console in the SC event log:

 scadm consolehistory [-a]

 Example 16 Viewing the Fruhistory

 The following command displays the content of the "field replacable
 unit" in the SC event log:

 scadm fruhistory [-a]

 Example 17 Viewing the Loghistory

 The following command displays the most recent entries in the SC event
 log:

 scadm loghistory [-a]

 Example 18 Displaying Verbose Information

 The following command displays verbose version information on the SC
 and its components:

 scadm version -v

 The following exit values are returned:

 0

 Successful completion.

 non-zero

 An error occurred.

 See attributes(5) for descriptions of the following attributes:

 ┌─────────────────────────────┬─────────────────────────────┐
 │ ATTRIBUTE TYPE │ ATTRIBUTE VALUE │
 ├─────────────────────────────┼─────────────────────────────┤
 │Availability │SUNWkvm │
 ├─────────────────────────────┼─────────────────────────────┤
 │Interface Stability │Evolving │
 └─────────────────────────────┴─────────────────────────────┘

 uname(1), syslog(3C), attributes(5)

SunOS 5.11 20 Dec 2005 scadm(1M)