sockio(7I)                      Ioctl Requests                      sockio(7I)

NAME

       sockio - ioctls that operate directly on sockets

SYNOPSIS

       #include <sys/sockio.h>

DESCRIPTION

       The  ioctls listed in this manual page apply directly to sockets, inde‐
       pendent of any underlying protocol. The setsockopt() call (see getsock‐
       opt(3SOCKET))  is  the  primary method for operating on sockets, rather
       than on the underlying protocol or network interface. ioctls for a spe‐
       cific  network  interface or protocol are documented in the manual page
       for that interface or protocol.

       SIOCSPGRP      The argument is a pointer to an int.  Set  the  process-
                      group  ID that will subsequently receive SIGIO or SIGURG
                      signals for the socket referred  to  by  the  descriptor
                      passed  to  ioctl to the value of that int. The argument
                      must be either positive (in which case  it  must   be  a
                      process  ID)  or  negative  (in  which case it must be a
                      process group).

       SIOCGPGRP      The argument is a pointer to an int. Set  the  value  of
                      that int to the process-group ID that is receiving SIGIO
                      or SIGURG signals for the  socket  referred  to  by  the
                      descriptor passed to ioctl.

       SIOCCATMARK    The  argument  is  a pointer to an int. Set the value of
                      that int to  1  if  the  read  pointer  for  the  socket
                      referred  to by the descriptor passed to ioctl points to
                      a mark in the data stream for  an  out-of-band  message.
                      Set  the  value of that int to 0 if the read pointer for
                      the socket referred to by the descriptor passed to ioctl
                      does not point to a mark in the data stream for an  out-
                      of-band message.

SEE ALSO

       ioctl(2), getsockopt(3SOCKET)

SunOS 5.11                        8 Nov 1996                        sockio(7I)
Impressum