pckt(7M) STREAMS Modules pckt(7M)

 pckt - STREAMS Packet Mode module

 int ioctl( fd, I_PUSH, "pckt");

 pckt is a STREAMS module that may be used with a pseudo terminal to
 packetize certain messages. The pckt module should be pushed (see
 I_PUSH on streamio(7I)) onto the master side of a pseudo terminal.

 Packetizing is performed by prefixing a message with an M_PROTO mes‐
 sage. The original message type is stored in the 1 byte data portion of
 the M_PROTO message.

 On the read-side, only the M_PROTO, M_PCPROTO, M_STOP, M_START,
 M_STOPI, M_STARTI, M_IOCTL, M_DATA, M_FLUSH, and M_READ messages are
 packetized. All other message types are passed upstream unmodified.

 Since all unread state information is held in the master's stream head
 read queue, flushing of this queue is disabled.

 On the write-side, all messages are sent down unmodified.

 With this module in place, all reads from the master side of the pseudo
 terminal should be performed with the getmsg(2) or getpmsg() function.
 The control part of the message contains the message type. The data
 part contains the actual data associated with that message type. The
 onus is on the application to separate the data into its component
 parts.

 getmsg(2), ioctl(2), ldterm(7M), ptem(7M), streamio(7I), termio(7I)

 STREAMS Programming Guide

SunOS 5.11 3 Jul 1990 pckt(7M)