print(9E)                     Driver Entry Points                    print(9E)

NAME

       print - display a driver message on system console

SYNOPSIS

       #include <sys/types.h>
       #include <sys/errno.h>
       #include <sys/ddi.h>
       #include <sys/sunddi.h>

       int prefixprint(dev_t dev, char *str);

INTERFACE LEVEL

       Architecture  independent  level  1  (DDI/DKI).  This  entry  point  is
       required for block devices.

PARAMETERS

       dev     Device number.

       str     Pointer to a character string describing the problem.

DESCRIPTION

       The print() routine is called by the kernel when  it  has  detected  an
       exceptional condition (such as out of space) in the device.  To display
       the message on the console, the driver should use the  cmn_err(9F) ker‐
       nel function. The driver should print the message along with any driver
       specific information.

RETURN VALUES

       The  print() routine should return 0 for success,  or  the  appropriate
       error  number.  The  print routine can fail if the driver implemented a
       non-standard  print() routine that attempted to perform error  logging,
       but was unable to complete the logging for whatever reason.

SEE ALSO

       cmn_err(9F)

       Writing Device Drivers

SunOS 5.11                        15 Sep 1992                        print(9E)
Impressum