tran_bus_reset(9E)            Driver Entry Points           tran_bus_reset(9E)

NAME

       tran_bus_reset - reset a SCSI bus

SYNOPSIS

       #include <sys/scsi/scsi.h> int prefix

       tran_bus_reset(dev_info_t *hba_dip, int level);

INTERFACE LEVEL

       Solaris DDI

PARAMETERS

       hba_dip    The  dev_info_t pointer associated with the SCSI HBA.

       level      The level of reset required.

DESCRIPTION

       The   tran_bus_reset() vector in the scsi_hba_tran(9S) structure should
       be initialized during the HBA driver's attach(9E). It is an  HBA  entry
       point  to  be  called  when a user initiates a bus reset through device
       control interfaces.

       tran_bus_reset() must reset the SCSI bus without resetting targets.

       level will be one of the following:

       RESET_BUS    Reset the SCSI bus only, not the targets.

       Implementation is hardware specific. If it is not possible to reset the
       SCSI  bus without changing the state and operating mode of the targets,
       the HBA driver should not initialize this vector or return failure.

RETURN VALUES

       tran_bus_reset() should return:

       1    on success.

       0    on failure.

ATTRIBUTES

       See attributes(5) for a description of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE         │      ATTRIBUTE VALUE        │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability          │Committed                    │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO

       attributes(5), tran_quiesce(9E), scsi_hba_tran(9S)

SunOS 5.11                        17 Mar 1999               tran_bus_reset(9E)
Impressum