ASSERT(9F)               Kernel Functions for Drivers               ASSERT(9F)

NAME

       ASSERT, assert - expression verification

SYNOPSIS

       #include <sys/debug.h>

       void ASSERT(EX);

INTERFACE LEVEL

       Architecture independent level 1 (DDI/DKI).

PARAMETERS

       EX    boolean expression.

DESCRIPTION

       The ASSERT() macro checks to see if the expression EX is true. If it is
       not, then ASSERT() causes an error message to be logged to the  console
       and the system to panic. ASSERT() works only if the preprocessor symbol
       DEBUG is defined.

CONTEXT

       The ASSERT() macro can be used from user, interrupt, or kernel context.

SEE ALSO

       Writing Device Drivers

SunOS 5.11                        16 Jan 2006                       ASSERT(9F)
Impressum