backq(9F)                Kernel Functions for Drivers                backq(9F)

NAME

       backq - get pointer to the queue behind the current queue

SYNOPSIS

       #include <sys/stream.h>

       queue_t *backq(queue_t *cq);

INTERFACE LEVEL

       Architecture independent level 1 (DDI/DKI).

PARAMETERS

       cq    The  pointer  to the current queue.   queue_t is an alias for the
             queue(9S) structure.

DESCRIPTION

       The backq() function returns a pointer to the queue preceding  cq  (the
       current queue). If cq is a read queue, backq() returns a pointer to the
       queue downstream from cq, unless it is the stream end. If cq is a write
       queue,  backq()  returns  a pointer to the next queue upstream from cq,
       unless it is the stream head.

RETURN VALUES

       If successful, backq() returns a pointer to  the  queue  preceding  the
       current queue. Otherwise, it returns NULL.

CONTEXT

       The backq() function can be called from user, interrupt, or kernel con‐
       text.

SEE ALSO

       queue(9S)

       Writing Device Drivers

       STREAMS Programming Guide

SunOS 5.11                        16 Jan 2006                        backq(9F)
Impressum