csx_FreeHandle(9F)       Kernel Functions for Drivers       csx_FreeHandle(9F)

NAME

       csx_FreeHandle - free access handle

SYNOPSIS

       #include <sys/pccard.h>

       int32_t csx_FreeHandle(acc_handle_t *handle);

INTERFACE LEVEL

       Solaris DDI Specific (Solaris DDI)

PARAMETERS

       handle     The   access   handle   returned   from   csx_RequestIO(9F),
                  csx_RequestWindow(9F), or csx_DupHandle(9F).

DESCRIPTION

       This function frees the handle, handle. If the handle  was  created  by
       the  csx_DupHandle(9F)  function,  this  function will free the storage
       associated with this handle, but will not modify any resources that the
       original handle refers to. If the handle was created by a common access
       setup function, this function will  release  the  resources  associated
       with this handle.

RETURN VALUES

       CS_SUCCESS                  Successful operation.

       CS_UNSUPPORTED_FUNCTION     No PCMCIA hardware installed.

CONTEXT

       This function may be called from user or kernel context.

SEE ALSO

       csx_DupHandle(9F), csx_RequestIO(9F), csx_RequestWindow(9F)

       PC Card95 Standard, PCMCIA/JEIDA

SunOS 5.11                        19 Jul 1996               csx_FreeHandle(9F)
Impressum