csx_RepPut8(9F) Kernel Functions for Drivers csx_RepPut8(9F)

 csx_RepPut8, csx_RepPut16, csx_RepPut32, csx_RepPut64 - write repeti‐
 tively to the device register

 #include <sys/pccard.h>

 void csx_RepPut8(acc_handle_t handle, uint8_t *hostaddr, uint32_t offset,
 uint32_t repcount, uint32_t flags);

 void csx_RepPut16(acc_handle_t handle, uint16_t *hostaddr, uint32_t offset,
 uint32_t repcount, uint32_t flags);

 void csx_RepPut32(acc_handle_t handle, uint32_t *hostaddr, uint32_t offset,
 uint32_t repcount, uint32_t flags);

 void csx_RepPut64(acc_handle_t handle, uint64_t *hostaddr, uint32_t offset,
 uint32_t repcount, uint32_t flags);

 Solaris DDI Specific (Solaris DDI)

 handle The access handle returned from csx_RequestIO(9F),
 csx_RequestWindow(9F), or csx_DupHandle(9F).

 hostaddr Source host address.

 offset The offset in bytes from the base of the mapped resource.

 repcount Number of data accesses to perform.

 flags Device address flags.

 These functions generate multiple writes of various sizes to the mapped
 memory or device register.

 The csx_RepPut8(), csx_RepPut16(), csx_RepPut32(), and csx_RepPut64()
 functions generate repcount writes of 8 bits, 16 bits, 32 bits, and 64
 bits of data, respectively, to the device address represented by the
 handle, handle, at an offset in bytes represented by the offset, off‐
 set. The data written is read consecutively from the buffer pointed to
 by the host address pointer, hostaddr.

 Data that consists of more than one byte will automatically be trans‐
 lated to maintain a consistent view between the host and the device
 based on the encoded information in the data access handle. The trans‐
 lation may involve byte swapping if the host and the device have incom‐
 patible endian characteristics.

 When the flags argument is set to CS_DEV_AUTOINCR, these functions
 increment the device offset, offset, after each datum write operation.
 However, when the flags argument is set to CS_DEV_NO_AUTOINCR, the same
 device offset will be used for every datum access. For example, this
 flag may be useful when writing to a data register.

 These functions may be called from user, kernel, or interrupt context.

 csx_DupHandle(9F), csx_Get8(9F), csx_GetMappedAddr(9F), csx_Put8(9F),
 csx_RepGet8(9F), csx_RequestIO(9F), csx_RequestWindow(9F)

 PC Card 95 Standard, PCMCIA/JEIDA

SunOS 5.11 19 Jul 1996 csx_RepPut8(9F)