csx_ValidateCIS(9F) Kernel Functions for Drivers csx_ValidateCIS(9F)

 csx_ValidateCIS - validate the Card Information Structure (CIS)

 #include <sys/pccard.h>

 int32_t csx_ValidateCIS(client_handle_t ch, cisinfo_t *ci);

 Solaris DDI Specific (Solaris DDI)

 ch Client handle returned from csx_RegisterClient(9F).

 ci Pointer to a cisinfo_t structure.

 This function validates the Card Information Structure (CIS) on the PC
 Card in the specified socket.

 The structure members of cisinfo_t are:

 uint32_t Socket; /* socket number to validate CIS on */
 uint32_t Chains; /* number of tuple chains in CIS */
 uint32_t Tuples; /* total number of tuples in CIS */

 The fields are defined as follows:

 Socket Not used in Solaris, but for portability with other Card Ser‐
 vices implementations, it should be set to the logical socket
 number.

 Chains This field returns the number of valid tuple chains located
 in the CIS. If 0 is returned, the CIS is not valid.

 Tuples This field is a Solaris-specific extension and it returns the
 total number of tuples on all the chains in the PC Card's
 CIS.

 CS_SUCCESS Successful operation.

 CS_NO_CIS No CIS on PC Card or CIS is invalid.

 CS_NO_CARD No PC Card in socket.

 CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed.

 This function may be called from user or kernel context.

 csx_GetFirstTuple(9F), csx_GetTupleData(9F), csx_ParseTuple(9F),
 csx_RegisterClient(9F)

 PC Card 95 Standard, PCMCIA/JEIDA

SunOS 5.11 19 Jul 1996 csx_ValidateCIS(9F)