ddi_dma_free_handle(9F) Kernel Functions for Drivers ddi_dma_free_handle(9F)

 ddi_dma_free_handle - free DMA handle

 #include <sys/ddi.h>
 #include <sys/sunddi.h>

 void ddi_dma_free_handle(ddi_dma_handle_t *handle);

 handle A pointer to the DMA handle previously allocated by a call
 to ddi_dma_alloc_handle(9F).

 Solaris DDI specific (Solaris DDI).

 ddi_dma_free_handle() destroys the DMA handle pointed to by handle.
 Any further references to the DMA handle will have undefined results.
 Note that ddi_dma_unbind_handle(9F) must be called prior to
 ddi_dma_free_handle() to free any resources the system may be caching
 on the handle.

 ddi_dma_free_handle() can be called from user, kernel, or interrupt
 context.

 ddi_dma_alloc_handle(9F), ddi_dma_unbind_handle(9F)

 Writing Device Drivers

SunOS 5.11 26 Sep 1994 ddi_dma_free_handle(9F)