ddi_dma_mem_free(9F) Kernel Functions for Drivers ddi_dma_mem_free(9F)

 ddi_dma_mem_free - free previously allocated memory

 #include <sys/ddi.h>
 #include <sys/sunddi.h>

 void ddi_dma_mem_free(ddi_acc_handle_t *handlep);

 handlep Pointer to the data access handle previously allocated by a
 call to ddi_dma_mem_alloc(9F).

 Solaris DDI specific (Solaris DDI).

 ddi_dma_mem_free() deallocates the memory acquired by
 ddi_dma_mem_alloc(9F). In addition, it destroys the data access handle
 handlep associated with the memory.

 ddi_dma_mem_free() can be called from user, kernel, or interrupt con‐
 text.

 ddi_dma_mem_alloc(9F)

 Writing Device Drivers

SunOS 5.11 26 Sep 1994 ddi_dma_mem_free(9F)